summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-08-09 20:36:05 +0100
committerSam James <sam@gentoo.org>2022-08-09 21:05:46 +0100
commitd24c7eb3dc2c532b84e7330bc7bec1d57b54ba48 (patch)
treebe5c0f372c1593edde966009bc1c982a6e5bcfd5
parentsys-apps/iproute2: add 5.19.0 (diff)
downloadgentoo-d24c7eb3dc2c532b84e7330bc7bec1d57b54ba48.tar.gz
gentoo-d24c7eb3dc2c532b84e7330bc7bec1d57b54ba48.tar.bz2
gentoo-d24c7eb3dc2c532b84e7330bc7bec1d57b54ba48.zip
sys-apps/iucode_tool: fix build on musl
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-apps/iucode_tool/files/iucode_tool-2.3.1-limits-include.patch10
-rw-r--r--sys-apps/iucode_tool/iucode_tool-2.3.1-r1.ebuild4
2 files changed, 14 insertions, 0 deletions
diff --git a/sys-apps/iucode_tool/files/iucode_tool-2.3.1-limits-include.patch b/sys-apps/iucode_tool/files/iucode_tool-2.3.1-limits-include.patch
new file mode 100644
index 000000000000..965bf740e3c2
--- /dev/null
+++ b/sys-apps/iucode_tool/files/iucode_tool-2.3.1-limits-include.patch
@@ -0,0 +1,10 @@
+Fixes build on musl.
+--- a/iucode_tool.c
++++ b/iucode_tool.c
+@@ -29,6 +29,7 @@
+ #include <assert.h>
+ #include <argp.h>
+ #include <dirent.h>
++#include <limits.h>
+ #include <time.h>
+ #include <cpuid.h>
diff --git a/sys-apps/iucode_tool/iucode_tool-2.3.1-r1.ebuild b/sys-apps/iucode_tool/iucode_tool-2.3.1-r1.ebuild
index 81dced5dc0e4..b6c3cb20991d 100644
--- a/sys-apps/iucode_tool/iucode_tool-2.3.1-r1.ebuild
+++ b/sys-apps/iucode_tool/iucode_tool-2.3.1-r1.ebuild
@@ -15,3 +15,7 @@ RDEPEND="elibc_musl? ( sys-libs/argp-standalone )"
DEPEND="${RDEPEND}"
S="${WORKDIR}/${PN/_/-}-${PV}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.3.1-limits-include.patch
+)