summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNHOrus <jy6x2b32pie9@yahoo.com>2024-04-26 13:19:22 +0400
committerPacho Ramos <pacho@gentoo.org>2024-06-01 12:45:29 +0200
commitd5911404bfb048c250e0150fce3ca0bcbdb2e42d (patch)
tree1efddaf33d9f4cf2f3fb91d03f17150d8a3e55a5
parentdev-ruby/dbf: Stabilize 4.3.2 x86, #933304 (diff)
downloadgentoo-d5911404bfb048c250e0150fce3ca0bcbdb2e42d.tar.gz
gentoo-d5911404bfb048c250e0150fce3ca0bcbdb2e42d.tar.bz2
gentoo-d5911404bfb048c250e0150fce3ca0bcbdb2e42d.zip
net-ftp/gftp: C99 porting, fix pointer type
Closes: https://bugs.gentoo.org/919288 Signed-off-by: NHOrus <jy6x2b32pie9@yahoo.com> Closes: https://github.com/gentoo/gentoo/pull/36430 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
-rw-r--r--net-ftp/gftp/files/gftp-2.9.1b-fix-socklen-type.patch11
-rw-r--r--net-ftp/gftp/gftp-2.9.1b-r1.ebuild46
2 files changed, 57 insertions, 0 deletions
diff --git a/net-ftp/gftp/files/gftp-2.9.1b-fix-socklen-type.patch b/net-ftp/gftp/files/gftp-2.9.1b-fix-socklen-type.patch
new file mode 100644
index 000000000000..f5bcdca11bbf
--- /dev/null
+++ b/net-ftp/gftp/files/gftp-2.9.1b-fix-socklen-type.patch
@@ -0,0 +1,11 @@
+--- a/lib/gftp.h 2024-04-26 09:08:32.404275437 +0000
++++ b/lib/gftp.h 2024-04-26 09:11:56.292057323 +0000
+@@ -361,7 +361,7 @@
+ int wakeup_main_thread[2]; /* FD that gets written to by the threads to wakeup the parent */
+
+ void *remote_addr;
+- size_t remote_addr_len;
++ socklen_t remote_addr_len;
+ int ai_family;
+ int ai_socktype;
+ unsigned int use_udp : 1; /* does this use UDP protocol? */
diff --git a/net-ftp/gftp/gftp-2.9.1b-r1.ebuild b/net-ftp/gftp/gftp-2.9.1b-r1.ebuild
new file mode 100644
index 000000000000..fd7704a41e9c
--- /dev/null
+++ b/net-ftp/gftp/gftp-2.9.1b-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gnome2
+
+DESCRIPTION="a free multithreaded file transfer client"
+HOMEPAGE="https://github.com/masneyb/gftp"
+SRC_URI="https://github.com/masneyb/gftp/releases/download/${PV}/${P}.tar.xz"
+
+# Override gnome.org.eclass's S= (bug #904064)
+S="${WORKDIR}/${P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="gtk ssl"
+
+RDEPEND="
+ dev-libs/glib:2
+ sys-libs/ncurses:0=
+ sys-libs/readline:0
+ gtk? ( x11-libs/gtk+:2 )
+ ssl? ( dev-libs/openssl:0= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ # https://github.com/masneyb/gftp/issues/178
+ "${FILESDIR}"/"${P}"-fix-socklen-type.patch
+)
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable gtk gtkport) \
+ $(use_enable ssl)
+}
+
+src_install() {
+ gnome2_src_install
+ dodoc docs/USERS-GUIDE
+}