summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Helmert III <ajak@gentoo.org>2024-09-01 22:58:00 -0700
committerJohn Helmert III <ajak@gentoo.org>2024-09-01 23:00:32 -0700
commitdb5243a984b4a04b871269f63ceb19ebaf4105ce (patch)
treee17beb9fb22b975444cc1f54a097955345a58594
parentapp-text/mdbook: keyword 0.4.40 for ~loong (diff)
downloadgentoo-db5243a984b4a04b871269f63ceb19ebaf4105ce.tar.gz
gentoo-db5243a984b4a04b871269f63ceb19ebaf4105ce.tar.bz2
gentoo-db5243a984b4a04b871269f63ceb19ebaf4105ce.zip
dev-util/rizin: fix tree-sitter-c automagic
Bug: https://bugs.gentoo.org/928301 Signed-off-by: John Helmert III <ajak@gentoo.org>
-rw-r--r--dev-util/rizin/rizin-0.7.3-r1.ebuild (renamed from dev-util/rizin/rizin-0.7.3.ebuild)6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-util/rizin/rizin-0.7.3.ebuild b/dev-util/rizin/rizin-0.7.3-r1.ebuild
index 5b8d7bfee238..9f446bfb76f0 100644
--- a/dev-util/rizin/rizin-0.7.3.ebuild
+++ b/dev-util/rizin/rizin-0.7.3-r1.ebuild
@@ -8,7 +8,7 @@ PYTHON_COMPAT=( python3_{10..13} )
# This is the commit that the CI for the release commit used
BINS_COMMIT="1203a9a2f51e32337c8434d9f4f7c4543552e271"
-inherit meson python-any-r1
+inherit flag-o-matic meson python-any-r1
DESCRIPTION="reverse engineering framework for binary analysis"
HOMEPAGE="https://rizin.re/"
@@ -36,6 +36,7 @@ RDEPEND="
dev-libs/openssl:0=
dev-libs/libpcre2:0=
>=dev-libs/tree-sitter-0.19.0
+ dev-libs/tree-sitter-c
dev-libs/xxhash
sys-apps/file
sys-libs/zlib:0=
@@ -69,6 +70,9 @@ src_prepare() {
}
src_configure() {
+ # workaround tree-sitter-c induced underlinking in bug 928301
+ append-ldflags -ltree-sitter
+
local emesonargs=(
-Dcli=enabled
-Duse_sys_capstone=enabled