summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorsin-ack <sin-ack@protonmail.com>2024-11-23 21:56:11 +0000
committerSam James <sam@gentoo.org>2024-12-01 11:45:51 +0000
commitddcb591be59ae925b85a66ccd5965a2aaa54e4a5 (patch)
tree01055d8ee7c26369502511808fdec6d61f0c64e5
parentdev-cpp/folly: install cmake files in the correct libdir (diff)
downloadgentoo-ddcb591be59ae925b85a66ccd5965a2aaa54e4a5.tar.gz
gentoo-ddcb591be59ae925b85a66ccd5965a2aaa54e4a5.tar.bz2
gentoo-ddcb591be59ae925b85a66ccd5965a2aaa54e4a5.zip
dev-cpp/folly: skip a test on system-libcxx systems
This test aborts with something about a threading-related assert in Folly. Signed-off-by: sin-ack <sin-ack@protonmail.com> Closes: https://github.com/gentoo/gentoo/pull/39437 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-cpp/folly/folly-2024.11.04.00-r2.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/dev-cpp/folly/folly-2024.11.04.00-r2.ebuild b/dev-cpp/folly/folly-2024.11.04.00-r2.ebuild
index 44a95b28d09a..d861968c9242 100644
--- a/dev-cpp/folly/folly-2024.11.04.00-r2.ebuild
+++ b/dev-cpp/folly/folly-2024.11.04.00-r2.ebuild
@@ -13,7 +13,7 @@ EAPI=8
# dev-cpp/wangle
# dev-util/watchman
-inherit flag-o-matic cmake
+inherit flag-o-matic cmake toolchain-funcs
DESCRIPTION="An open-source C++ library developed and used at Facebook"
HOMEPAGE="https://github.com/facebook/folly"
@@ -101,5 +101,13 @@ src_test() {
)
fi
+ if [[ $(tc-get-cxx-stdlib) == libc++ ]]; then
+ CMAKE_SKIP_TESTS+=(
+ # Aborts with libc++.
+ # https://github.com/facebook/folly/issues/2345
+ buffered_atomic_test.BufferedAtomic.singleThreadUnguardedAccess
+ )
+ fi
+
cmake_src_test
}