summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-09 09:48:02 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-09 10:07:58 +0100
commitdfd859db752936a13c1f01bd53688d6f685b71d2 (patch)
treef4752447cb077e9ee183922d88a9ffeacbbf2f76
parentdev-python/botocore: Bump to 1.23.51 (diff)
downloadgentoo-dfd859db752936a13c1f01bd53688d6f685b71d2.tar.gz
gentoo-dfd859db752936a13c1f01bd53688d6f685b71d2.tar.bz2
gentoo-dfd859db752936a13c1f01bd53688d6f685b71d2.zip
dev-python/boto3: Bump to 1.20.51
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.20.51.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 60678dd3b5c5..209f4b1b4fd3 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -5,3 +5,4 @@ DIST boto3-1.20.47.tar.gz 465774 BLAKE2B ab615d29d79b209671808770968c38c2ef26b83
DIST boto3-1.20.48.tar.gz 466063 BLAKE2B 7ba92d1cfbd576d4262e0f99a9e9aa118747fbbe60caa703c14f24559d4c2312b3e7695c40b6555bd58f7beb248e7ecfcedd64bc84badb44cb96812c9537cabe SHA512 e80f2e54909a3a54e5eba9c9a75c0ccbb2ba3f8907dfec9563f50bef1be56b82b593ae0bc0ee0bfab1a7c993d4bbf0c624486822ef3cd93ef425f39205b628f0
DIST boto3-1.20.49.tar.gz 466426 BLAKE2B 82f2ed7f14576afd5a4d2dab91b99986904fef97b98460dce152e0806cb20e39b14975e4c3362c9d208c4dce9de3e7a4fa9fa60559aa0007ff735ce9e43995e4 SHA512 6ea92236726b9200a8b06f773483b0d6803585480cfad1f68eab227598ca86c3aa93cbeccec5338febc52eb48691f003c5983d52be56dd91e97735ddbfac7053
DIST boto3-1.20.50.tar.gz 466795 BLAKE2B 662284de4654781391605fba93f401ec24300abab696c02146739598e9206598e92539ff9468f99b108d3ac00f72555945986e04e2b6625baace11b8f9b746ef SHA512 103a75edc907ea9a7ed5d08bb8a2f31b1360495a130d0492461956c0ec5c1e1b839187d9d9feaebf7eb06e2d367f9fcdc1c522c234be3314fceca7884651d54e
+DIST boto3-1.20.51.tar.gz 467620 BLAKE2B 18cb273cd7af7184baa40b5ac98be270324e221f8fd408b3f4ecf1d1cfff387af84d72207281f6ac906c1f55048d603001d865acc509451b555fa57a3b1f848e SHA512 c4a3ab6460e58e3bad305dbd12b4719b07ee0c92bed30e1fff017d6df93883f50fca388389c1cf8b474c42c049f189106c3e71f087e7fe9c921b81c796acc70b
diff --git a/dev-python/boto3/boto3-1.20.51.ebuild b/dev-python/boto3/boto3-1.20.51.ebuild
new file mode 100644
index 000000000000..48ea5aa483a1
--- /dev/null
+++ b/dev-python/boto3/boto3-1.20.51.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit}
+}