summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-20 07:43:42 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-20 09:07:04 +0100
commite79f4ee51c2532ac66eccb3f0bc9fccc9dbc12bb (patch)
treefe60e79de288cb25232821e2829ccc410d40cb83
parentdev-python/botocore: Bump to 1.29.33 (diff)
downloadgentoo-e79f4ee51c2532ac66eccb3f0bc9fccc9dbc12bb.tar.gz
gentoo-e79f4ee51c2532ac66eccb3f0bc9fccc9dbc12bb.tar.bz2
gentoo-e79f4ee51c2532ac66eccb3f0bc9fccc9dbc12bb.zip
dev-python/boto3: Bump to 1.26.33
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.26.33.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 008b1a4f26e3..6a83f0a6f92a 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -2,3 +2,4 @@ DIST boto3-1.26.20.gh.tar.gz 572957 BLAKE2B 27286beaeabc0227376640fd3ee583656470
DIST boto3-1.26.29.gh.tar.gz 578484 BLAKE2B 5914f5f19072268f6b5f90571f0ec573632f8e0546010a754d3116b18bd0d4236af2aa4f94a15778134d2b90f3fa80feadf8355a3015932b33cfec64a8917471 SHA512 a30e783b627bdbe6b723eb635702f0fbbe38d48eaaba7e93c880dd9f462d6257ed5a7ee524a096c42978d43336bfc6327a999de794c39877214e1d71ce1ab363
DIST boto3-1.26.31.gh.tar.gz 580080 BLAKE2B 30d44e3df131aef363ccc2afdde43ee4b0d11d232b7af532915f1c66090616a3154f85269481f41e00e0553d87a8ad178ab3b9c8296e58c6b68723674450e6e1 SHA512 021b9a5c2d1f1555a7632e2d688ae7cebc0b51e572ccec35b81c75354f68d7fdd4482fb7de6e617bd13334a15cba2db52a2502f6b421df130645ea7d037f810c
DIST boto3-1.26.32.gh.tar.gz 581235 BLAKE2B f8decc1e924ff5f5f98566084a55c36ea10ca38596e0f8398a9d5865e6246290e9e09ff3e95622eacca9f32b6f8119156b2ba5a6ce0135e988fad0bcdb161030 SHA512 73c6f8f1e1d5f12887e880cc651399fbd147c65740090bd09303540dcc902efc6b04605551f055341e84cb8b72cdcb9d8d444263fc0131b8f5013197e67c1fb5
+DIST boto3-1.26.33.gh.tar.gz 581883 BLAKE2B a2ac93a516932b8cfcb039e215608ebdd3f5427c7abb016359ad2f1a9e5e4ed855a405bb0470b5ba4823ba59c21d21f2b3319dcc8ef0715a1293cb0219261ac1 SHA512 4bb267abfaa01643edd6670dc66c87225845dce31d1d4aa500f60a278326a8fe6f877d8af4bff460cea3b77ef316392a2acf10181d7ae2a7c59ca2f6ca5ec9aa
diff --git a/dev-python/boto3/boto3-1.26.33.ebuild b/dev-python/boto3/boto3-1.26.33.ebuild
new file mode 100644
index 000000000000..6edcc751d54b
--- /dev/null
+++ b/dev-python/boto3/boto3-1.26.33.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}