summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatoro Mahri <matoro_gentoo@matoro.tk>2023-12-14 14:21:05 -0500
committerSam James <sam@gentoo.org>2023-12-19 05:25:52 +0000
commitf6f136bbc813ef7a65358e7f5712a3d49395d717 (patch)
treef2faec69ebc2082716518ccb56b9f92d94231c34
parentdev-util/vulkan-utility-libraries: wire up tests (diff)
downloadgentoo-f6f136bbc813ef7a65358e7f5712a3d49395d717.tar.gz
gentoo-f6f136bbc813ef7a65358e7f5712a3d49395d717.tar.bz2
gentoo-f6f136bbc813ef7a65358e7f5712a3d49395d717.zip
dev-util/babeltrace: add 2.0.5
Closes: https://bugs.gentoo.org/872992 Signed-off-by: Matoro Mahri <matoro_gentoo@matoro.tk> Closes: https://github.com/gentoo/gentoo/pull/34286 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-util/babeltrace/Manifest1
-rw-r--r--dev-util/babeltrace/babeltrace-2.0.5.ebuild56
-rw-r--r--dev-util/babeltrace/metadata.xml7
3 files changed, 64 insertions, 0 deletions
diff --git a/dev-util/babeltrace/Manifest b/dev-util/babeltrace/Manifest
index e359f37d023a..61550ab9de38 100644
--- a/dev-util/babeltrace/Manifest
+++ b/dev-util/babeltrace/Manifest
@@ -1 +1,2 @@
DIST babeltrace-1.5.8.tar.bz2 992610 BLAKE2B 3d47f9ba40b406271a0b35e441968718c93e8744f95b56f79acf8359001ebffb4966931f2860d48ced4f0d98261b37156564a0d798bf8d9e0ed465c05355cc5d SHA512 827749ae8507efd433bb97ef668628837a3ff15b5be5097af5621d46055c6f10401da0be1f9d9f843a96c8c307b33745e04284d166e275e03b7ddb0a7dd57e96
+DIST babeltrace2-2.0.5.tar.bz2 3252593 BLAKE2B 31a8f3c080e4a6b6e33c224ec4a64d5ff12724a5697954cb92b88c569d6f2019f49ddcb88f82d36be3007c7b5d1334370202d1c0e89122acf340a7cb9e399fa3 SHA512 63469cb0796c720b18bfc09569875eb9a44d2f8a776228bfa503af8ba613b2988b2d20be870f41451e5d6146a3dfb08de6284131d25f1a86137deb75c3a4d514
diff --git a/dev-util/babeltrace/babeltrace-2.0.5.ebuild b/dev-util/babeltrace/babeltrace-2.0.5.ebuild
new file mode 100644
index 000000000000..a2ef0478d2cc
--- /dev/null
+++ b/dev-util/babeltrace/babeltrace-2.0.5.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+inherit python-single-r1
+
+DESCRIPTION="A command-line tool and library to read and convert trace files"
+HOMEPAGE="https://babeltrace.org/"
+SRC_URI="https://www.efficios.com/files/${PN}/${PN}$(ver_cut 1)-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0/$(ver_cut 1)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="doc +elfutils +man plugins python"
+REQUIRED_USE="plugins? ( python ) python? ( ${PYTHON_REQUIRED_USE} )"
+S="${WORKDIR}/${PN}$(ver_cut 1)-${PV}"
+
+RDEPEND=">=dev-libs/glib-2.28:2
+ elfutils? ( >=dev-libs/elfutils-0.154 )
+ python? ( ${PYTHON_DEPS} )
+"
+
+BDEPEND="${RDEPEND}
+ >=sys-devel/bison-2.5
+ >=sys-devel/flex-2.5.35
+ python? (
+ >=dev-lang/swig-3.0
+ $(python_gen_cond_dep 'dev-python/setuptools[${PYTHON_USEDEP}]' python3_12)
+ doc? ( >=dev-python/sphinx-1.3 )
+ )
+ doc? ( >=app-doc/doxygen-1.8.6 )
+ man? (
+ >=app-text/asciidoc-8.6.8
+ >=app-text/xmlto-0.0.25
+ )
+"
+
+src_configure() {
+ use python && export PYTHON_CONFIG="${EPYTHON}-config"
+ econf \
+ $(use_enable doc api-doc) \
+ $(use_enable elfutils debug-info) \
+ $(use_enable man man-pages) \
+ $(use_enable python python-bindings) \
+ $(usex python $(use_enable doc python-bindings-doc) --disable-python-bindings-doc) \
+ $(use_enable plugins python-plugins) \
+ --disable-built-in-plugins \
+ --disable-built-in-python-plugin-support
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
diff --git a/dev-util/babeltrace/metadata.xml b/dev-util/babeltrace/metadata.xml
index e19173f54746..4a8c91ec4791 100644
--- a/dev-util/babeltrace/metadata.xml
+++ b/dev-util/babeltrace/metadata.xml
@@ -5,4 +5,11 @@
<longdescription>
Babeltrace is a command-line tool and library to read and convert trace files to and from different formats. It supports the CTF format, which is outputted by the LTTng 2.0 tracers.
</longdescription>
+ <use>
+ <flag name="elfutils">Build the <pkg>dev-util/lttng-ust</pkg> debug information filter component class</flag>
+ <flag name="plugins">Build support for Babeltrace 2 Python plugins</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">efficios/babeltrace</remote-id>
+ </upstream>
</pkgmetadata>