summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-accessibility/powiedz
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-accessibility/powiedz')
-rw-r--r--app-accessibility/powiedz/Manifest1
-rw-r--r--app-accessibility/powiedz/files/powiedz-dsp-handle-fix.patch13
-rw-r--r--app-accessibility/powiedz/files/powiedz.desktop8
-rw-r--r--app-accessibility/powiedz/metadata.xml6
-rw-r--r--app-accessibility/powiedz/powiedz-1.0-r2.ebuild31
5 files changed, 59 insertions, 0 deletions
diff --git a/app-accessibility/powiedz/Manifest b/app-accessibility/powiedz/Manifest
new file mode 100644
index 000000000000..ec394b71e210
--- /dev/null
+++ b/app-accessibility/powiedz/Manifest
@@ -0,0 +1 @@
+DIST powiedz-1.0.tgz 68672 SHA256 cd13de1b45c8dae8046b3bb522a0bbf6416d3205d74091e2995bd6c9a9834b5c SHA512 1a572ead0c6358b52ef4b5efc66dd633b2c7cb35c97bc911ce46f54fd84f626ca73b4be9951fb48688abaac4fab41f0a5087dbd89fecc91fc9e42f944e188eb3 WHIRLPOOL 2fde99fd75cfbc3ea82596aa3f43a580ea6a0c625dbf3ce78b3cb333467d36c6b56d49e5858fc4630428d0f7e5b6d0fb3810a4b3200b9d691c476d3e14ccddf8
diff --git a/app-accessibility/powiedz/files/powiedz-dsp-handle-fix.patch b/app-accessibility/powiedz/files/powiedz-dsp-handle-fix.patch
new file mode 100644
index 000000000000..f18761aff89e
--- /dev/null
+++ b/app-accessibility/powiedz/files/powiedz-dsp-handle-fix.patch
@@ -0,0 +1,13 @@
+diff -urN aaa/powiedz/aufile.c powiedz/aufile.c
+--- aaa/powiedz/aufile.c 2003-08-30 20:57:37.000000000 +0200
++++ powiedz/aufile.c 2003-08-31 14:02:42.000000000 +0200
+@@ -217,8 +217,7 @@
+ audio_open(int samp_rate,int disp)
+ {
+ int i;
+-// esd_fd = open(dev_file, O_WRONLY | O_NDELAY);
+- esd_fd = open(audio_dsp, O_WRONLY);
++ esd_fd = open(audio_dsp, O_WRONLY | O_NDELAY);
+ if (esd_fd < 0)
+ {
+ if (disp) perror(audio_dsp);
diff --git a/app-accessibility/powiedz/files/powiedz.desktop b/app-accessibility/powiedz/files/powiedz.desktop
new file mode 100644
index 000000000000..2ea1c4820f69
--- /dev/null
+++ b/app-accessibility/powiedz/files/powiedz.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=Powiedz
+Comment=Polish speak synthesizer
+Comment[pl]=Polski syntezator mowy
+Exec=powiedz
+Type=Application
+Terminal=false
+Categories=AudioVideo;Audio;
diff --git a/app-accessibility/powiedz/metadata.xml b/app-accessibility/powiedz/metadata.xml
new file mode 100644
index 000000000000..42fd1198f93a
--- /dev/null
+++ b/app-accessibility/powiedz/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>accessibility</herd>
+ <herd>sound</herd>
+</pkgmetadata>
diff --git a/app-accessibility/powiedz/powiedz-1.0-r2.ebuild b/app-accessibility/powiedz/powiedz-1.0-r2.ebuild
new file mode 100644
index 000000000000..b7c1b81df73b
--- /dev/null
+++ b/app-accessibility/powiedz/powiedz-1.0-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Polish speech synthesizer based on rsynth"
+HOMEPAGE="http://kadu.net/index.php?page=download&lang=en"
+SRC_URI="http://kadu.net/download/additions/powiedz-1.0.tgz"
+
+LICENSE="GPL-1"
+SLOT="0"
+KEYWORDS="amd64 ppc ~sparc x86"
+IUSE=""
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-dsp-handle-fix.patch
+}
+
+src_compile() {
+ emake -f Makefile_plain LDLIBS="-lm" CFLAGS="${CFLAGS}" DEFS="" CC=$(tc-getCC)
+}
+
+src_install() {
+ dobin powiedz
+ domenu "${FILESDIR}"/${PN}.desktop
+}