summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2023-07-18 13:10:35 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2023-07-18 13:10:58 -0500
commit761979dd4d6ab72b821e2adb45ab8b77fea595fd (patch)
tree38423fc4ccdeb7cf995b5803574f64be51ab28ce /app-admin/ansible/ansible-7.7.0.ebuild
parentapp-admin/ansible: add 8.2.0 (diff)
downloadgentoo-761979dd4d6ab72b821e2adb45ab8b77fea595fd.tar.gz
gentoo-761979dd4d6ab72b821e2adb45ab8b77fea595fd.tar.bz2
gentoo-761979dd4d6ab72b821e2adb45ab8b77fea595fd.zip
app-admin/ansible: add 7.7.0
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-admin/ansible/ansible-7.7.0.ebuild')
-rw-r--r--app-admin/ansible/ansible-7.7.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-admin/ansible/ansible-7.7.0.ebuild b/app-admin/ansible/ansible-7.7.0.ebuild
new file mode 100644
index 000000000000..b74fccd0afab
--- /dev/null
+++ b/app-admin/ansible/ansible-7.7.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Model-driven deployment, config management, and command execution framework"
+HOMEPAGE="https://www.ansible.com/"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~x64-macos"
+RESTRICT="test"
+
+RDEPEND=">=app-admin/ansible-core-2.14.0
+ <app-admin/ansible-core-2.15"
+
+python_compile() {
+ local -x ANSIBLE_SKIP_CONFLICT_CHECK=1
+ distutils-r1_python_compile
+}
+python_install() {
+ local -x ANSIBLE_SKIP_CONFLICT_CHECK=1
+ distutils-r1_python_install
+}