summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-19 07:36:56 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-19 08:57:13 +0200
commite214ee4d36fd9f996bf85b1b6b11697aae894c91 (patch)
tree296ab6fa3edcad3b21d23dd0cc4728ef91dc1e85 /app-admin/awscli
parentdev-python/boto3: Bump to 1.28.5 (diff)
downloadgentoo-e214ee4d36fd9f996bf85b1b6b11697aae894c91.tar.gz
gentoo-e214ee4d36fd9f996bf85b1b6b11697aae894c91.tar.bz2
gentoo-e214ee4d36fd9f996bf85b1b6b11697aae894c91.zip
app-admin/awscli: Bump to 1.29.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin/awscli')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.29.5.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index b6ecb7511fa5..5478bf64127c 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -11,3 +11,4 @@ DIST aws-cli-1.29.1.gh.tar.gz 2449948 BLAKE2B 5765a91501be6d789610be4d46373c909f
DIST aws-cli-1.29.2.gh.tar.gz 2449985 BLAKE2B a5a5ce673930971c9c03f9869e3b3d49a13cfb74cb1499e1ae3a6fccad65d8f996138bbde81f633d29ffeaec51902059255e6315ac5407c4c6c19845e71454c5 SHA512 b68e81778a62abd38c70d7b9d1039e47f3ae979e62a55919d989e7ccdb6ea370a58caa3584df34a2d96d601436bd3cf5261f491031b211305b1e9d5aee1a4923
DIST aws-cli-1.29.3.gh.tar.gz 2450427 BLAKE2B 6e240905c8fbb2916334c2de0e9fd851636acfbc050916baf971e2f5e5a1d93d398c77c6a1fe0766f701ad53683e5f41b1bb5519e5ac7b5e8f0a64d37e113c34 SHA512 3446e057abcc956e26b55de85383d0d40c041bcfda0f7e566309d80bbd22d567a474d93ab74461e91bdd7eaff1db9c77813912653c7864bcc851d12d2cea8ee2
DIST aws-cli-1.29.4.gh.tar.gz 2451404 BLAKE2B cafdfd6431b1b6720a89e2f8f5c1fe2a356c482ba57fd8c201dc9c4ca407700b529a3d4d101c3a1b7e33bb220f22d04da1bc9ebd14be00fe7faec8a834dad60b SHA512 0fe222ffe6298e7e9216089f553e4ef6e50111fcc11b9906871220624a5ea2828c47f4ca4a8251068a749ffd042a140529d9af487db169f46740b93501f00b9d
+DIST aws-cli-1.29.5.gh.tar.gz 2451819 BLAKE2B ab468b3d2114a156163063c760e0274f7a606d45e51e7b498304ecb7a53dbd098a7d6930c80604625353512100a2c7c321842f8dd10072f451e68ab55ee4d8e2 SHA512 a5d6dacc5831198a0e32e80d86c69c6d25ed83c6d7102aae964c4ddb9f12963b227bfe7652d6a4f54875fc622203536b5c200fe143de79ff6c9c78dd6ecbc11e
diff --git a/app-admin/awscli/awscli-1.29.5.ebuild b/app-admin/awscli/awscli-1.29.5.ebuild
new file mode 100644
index 000000000000..62c19f3a63fb
--- /dev/null
+++ b/app-admin/awscli/awscli-1.29.5.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit bash-completion-r1 distutils-r1 multiprocessing
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.(y+2).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ tests/functional/eks/test_kubeconfig.py::TestKubeconfigLoader::test_load_simple
+ tests/unit/customizations/eks/test_update_kubeconfig.py::TestKubeconfigSelector::test_choose_env_only
+ tests/unit/customizations/eks/test_update_kubeconfig.py::TestKubeconfigSelector::test_choose_existing
+ tests/unit/customizations/eks/test_kubeconfig.py::TestKubeconfigValidator::test_valid
+ )
+
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)" --forked
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}