summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Mozes <hydrapolic@gmail.com>2018-04-20 14:07:45 +0200
committerMichał Górny <mgorny@gentoo.org>2018-04-20 14:51:18 +0200
commit843ee10f7ce5de476e9cc31c7ac4e3e22e70bc93 (patch)
tree290f24db331121bea1b25ab8f80115d4748dca91 /app-admin/filebeat/filebeat-6.2.4.ebuild
parentapp-admin/filebeat: bump to 5.6.9 (diff)
downloadgentoo-843ee10f7ce5de476e9cc31c7ac4e3e22e70bc93.tar.gz
gentoo-843ee10f7ce5de476e9cc31c7ac4e3e22e70bc93.tar.bz2
gentoo-843ee10f7ce5de476e9cc31c7ac4e3e22e70bc93.zip
app-admin/filebeat: bump to 6.2.4
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'app-admin/filebeat/filebeat-6.2.4.ebuild')
-rw-r--r--app-admin/filebeat/filebeat-6.2.4.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/app-admin/filebeat/filebeat-6.2.4.ebuild b/app-admin/filebeat/filebeat-6.2.4.ebuild
new file mode 100644
index 000000000000..cf379ba2e314
--- /dev/null
+++ b/app-admin/filebeat/filebeat-6.2.4.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eapi7-ver
+
+DESCRIPTION="Lightweight log shipper for Logstash and Elasticsearch"
+HOMEPAGE="https://www.elastic.co/products/beats"
+SRC_URI="https://github.com/elastic/beats/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test"
+
+DEPEND=">=dev-lang/go-1.9.2"
+RDEPEND="!app-admin/filebeat-bin"
+
+S="${WORKDIR}/src/github.com/elastic/beats"
+
+src_unpack() {
+ mkdir -p "${S%/*}" || die
+ default
+ mv beats-${PV} "${S}" || die
+}
+
+src_compile() {
+ GOPATH="${WORKDIR}" emake -C "${S}/filebeat"
+}
+
+src_install() {
+ keepdir /var/{lib,log}/${PN}
+
+ fperms 0750 /var/{lib,log}/${PN}
+
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+ newinitd "${FILESDIR}/${PN}.initd.1" ${PN}
+
+ docinto examples
+ dodoc ${PN}/{filebeat.yml,filebeat.reference.yml}
+
+ dobin filebeat/filebeat
+}
+
+pkg_postinst() {
+ if [[ -n "${REPLACING_VERSIONS}" ]]; then
+ elog "Please read the migration guide at:"
+ elog "https://www.elastic.co/guide/en/beats/libbeat/$(ver_cut 1-2)/upgrading.html"
+ elog ""
+ fi
+
+ elog "Example configurations:"
+ elog "${EROOT%/}/usr/share/doc/${PF}/examples"
+}