summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenrik Pihl <ahvenas@gmail.com>2020-08-01 12:53:53 +0300
committerJoonas Niilola <juippis@gentoo.org>2020-08-15 12:29:45 +0300
commitfaca8e5bf131adecf368e32a329ac725c65ae307 (patch)
tree6d1007ecbdddf53a83f2b4332d922819ce7b85ee /app-admin/gtkdiskfree/gtkdiskfree-2.0.4_p20200224.ebuild
parentdev-cpp/ctemplate: add 2.4 (diff)
downloadgentoo-faca8e5bf131adecf368e32a329ac725c65ae307.tar.gz
gentoo-faca8e5bf131adecf368e32a329ac725c65ae307.tar.bz2
gentoo-faca8e5bf131adecf368e32a329ac725c65ae307.zip
app-admin/gtkdiskfree: version bump, move to EAPI 7
- Use the latest commit for this release, fixes lot of UI related visual issues not in a release yet. - Not using a separate USE flag for gtk 3 and the old color selector, as initially suggested in the bug. Closes: https://bugs.gentoo.org/665026 Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Henrik Pihl <ahvenas@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/16925 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-admin/gtkdiskfree/gtkdiskfree-2.0.4_p20200224.ebuild')
-rw-r--r--app-admin/gtkdiskfree/gtkdiskfree-2.0.4_p20200224.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-admin/gtkdiskfree/gtkdiskfree-2.0.4_p20200224.ebuild b/app-admin/gtkdiskfree/gtkdiskfree-2.0.4_p20200224.ebuild
new file mode 100644
index 000000000000..cfaa632c8975
--- /dev/null
+++ b/app-admin/gtkdiskfree/gtkdiskfree-2.0.4_p20200224.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Graphical tool to show free disk space like df"
+HOMEPAGE="https://gitlab.com/mazes_80/gtkdiskfree"
+COMMIT="bdda379b9109a226a37801505a19da91494144a6"
+SRC_URI="https://gitlab.com/mazes_80/${PN}/-/archive/${COMMIT}/${PN}-${COMMIT}.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="gtk2"
+
+DEPEND="
+ dev-libs/glib
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ gtk2? ( x11-libs/gtk+:2 )
+ !gtk2? ( x11-libs/gtk+:3 )"
+RDEPEND="${DEPEND}"
+BDEPEND="sys-devel/gettext
+ virtual/pkgconfig"
+
+src_configure() {
+ if use gtk2 ; then
+ econf $(use_with gtk2)
+ else
+ econf --enable-old-color-selector
+ fi
+}