summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Karbowski <slashbeast@gentoo.org>2021-07-15 22:43:30 +0200
committerPiotr Karbowski <slashbeast@gentoo.org>2021-07-15 23:23:22 +0200
commit8ad93a953cb9e720eec04360dc9875ff950e73b3 (patch)
tree0df4ab167143e2c8cb1f713d561079a1e0d499ab /app-admin/ryzen_smu/ryzen_smu-0.1.2_p20210627.ebuild
parentdev-python/cython: Bump to 0.29.24 (diff)
downloadgentoo-8ad93a953cb9e720eec04360dc9875ff950e73b3.tar.gz
gentoo-8ad93a953cb9e720eec04360dc9875ff950e73b3.tar.bz2
gentoo-8ad93a953cb9e720eec04360dc9875ff950e73b3.zip
app-admin/ryzen_smu: new package.
Signed-off-by: Piotr Karbowski <slashbeast@gentoo.org>
Diffstat (limited to 'app-admin/ryzen_smu/ryzen_smu-0.1.2_p20210627.ebuild')
-rw-r--r--app-admin/ryzen_smu/ryzen_smu-0.1.2_p20210627.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-admin/ryzen_smu/ryzen_smu-0.1.2_p20210627.ebuild b/app-admin/ryzen_smu/ryzen_smu-0.1.2_p20210627.ebuild
new file mode 100644
index 000000000000..74f80a772eb0
--- /dev/null
+++ b/app-admin/ryzen_smu/ryzen_smu-0.1.2_p20210627.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-mod linux-info
+
+SRC_URI="https://dev.gentoo.org/~slashbeast/distfiles/${PN}/${P}.tar.xz"
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Kernel driver for AMD Ryzen's System Management Unit"
+HOMEPAGE="https://github.com/leogx9r/ryzen_smu"
+
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+MODULE_NAMES="ryzen_smu(misc)"
+
+pkg_setup() {
+ linux_config_exists
+
+ linux-mod_pkg_setup
+
+ BUILD_TARGETS="modules"
+ BUILD_PARAMS="CC=$(tc-getBUILD_CC) KERNEL_BUILD=${KERNEL_DIR}"
+}
+
+src_install() {
+ linux-mod_src_install
+ insinto /usr/lib/modules-load.d/
+ newins "${FILESDIR}"/ryzen_smu.conf ryzen_smu.conf
+
+}