summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-02-20 21:35:45 -0800
committerMatt Turner <mattst88@gentoo.org>2022-02-20 21:48:28 -0800
commit661f0689f4213c1ef65316005517f6c9e6edd2fa (patch)
tree8ce0ff5e7350de087b81ee7a868f873d4c912cf6 /app-admin/system-config-printer
parentdev-libs/expat: Stabilize 2.4.6 arm, #833633 (diff)
downloadgentoo-661f0689f4213c1ef65316005517f6c9e6edd2fa.tar.gz
gentoo-661f0689f4213c1ef65316005517f6c9e6edd2fa.tar.bz2
gentoo-661f0689f4213c1ef65316005517f6c9e6edd2fa.zip
app-admin/system-config-printer: Version bump to 1.5.16
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-admin/system-config-printer')
-rw-r--r--app-admin/system-config-printer/Manifest1
-rw-r--r--app-admin/system-config-printer/system-config-printer-1.5.16.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/app-admin/system-config-printer/Manifest b/app-admin/system-config-printer/Manifest
index 15de7f12123b..ae5ba9287fb8 100644
--- a/app-admin/system-config-printer/Manifest
+++ b/app-admin/system-config-printer/Manifest
@@ -1 +1,2 @@
DIST system-config-printer-1.5.15.tar.xz 1005764 BLAKE2B 4919c555444829505b09b658ce0fd016ba235260f8c8b4db751e6a511afba5d5975e5f9570f5fe74fc35d158bbf2dd3ece99aa568ec1bb850096e5f12f0fc0b0 SHA512 b992f96f48c54350c11c5c629e77ee4409fe52fb17b386f226a42d532a95e17b6506319dcedeb70c0072555cb9ab464daaae22f295ce3d5181e5f49836f2ae2e
+DIST system-config-printer-1.5.16.tar.xz 1382124 BLAKE2B 37548bd470f8e80026e014d4077a79a38ad54258d620654536890b67b688fc790c9a9a269b321f2e12d63ec21f24858866e39b41089195c528ddbdf1351bba5f SHA512 ed20a409def66bdea7de4cd5b397891eca220c841e1b5c8cab98e45f87389ae8ba881d9e24072dd07203141fc34c49c4b67cf099791857c007971e3b7d2e2fc2
diff --git a/app-admin/system-config-printer/system-config-printer-1.5.16.ebuild b/app-admin/system-config-printer/system-config-printer-1.5.16.ebuild
new file mode 100644
index 000000000000..943232fba7a0
--- /dev/null
+++ b/app-admin/system-config-printer/system-config-printer-1.5.16.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="xml"
+inherit python-single-r1 systemd xdg
+
+DESCRIPTION="Graphical user interface for CUPS administration"
+HOMEPAGE="https://github.com/OpenPrinting/system-config-printer"
+SRC_URI="https://github.com/OpenPrinting/${PN}/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="gnome-keyring policykit"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# Needs cups running, bug 284005
+RESTRICT="test"
+
+# Additional unhandled dependencies
+# gnome-extra/gnome-packagekit[${PYTHON_USEDEP}] with pygobject:2 ?
+# python samba client: smbc
+# selinux: needed for troubleshooting
+COMMON_DEPEND="${PYTHON_DEPS}
+ dev-libs/glib:2
+ net-print/cups[dbus]
+ virtual/libusb:1
+ >=virtual/udev-172
+ x11-libs/gtk+:3[introspection]
+ x11-libs/libnotify[introspection]
+ x11-libs/pango[introspection]
+"
+DEPEND="${COMMON_DEPEND}
+ app-text/docbook-xml-dtd:4.1.2
+ >=app-text/xmlto-0.0.22
+ dev-perl/XML-Parser
+ dev-util/desktop-file-utils
+ dev-util/intltool
+ >=sys-devel/gettext-0.20
+ virtual/pkgconfig
+"
+RDEPEND="${COMMON_DEPEND}
+ $(python_gen_cond_dep '
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pycups[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ ')
+ gnome-keyring? ( app-crypt/libsecret[introspection] )
+ policykit? ( net-print/cups-pk-helper )
+"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local myeconfargs=(
+ --with-xmlto
+ --enable-nls
+ --with-desktop-vendor=Gentoo
+ --with-udev-rules
+ --with-systemdsystemunitdir=$(systemd_get_systemunitdir)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ python_fix_shebang "${ED}"
+ python_optimize
+}