summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-21 06:50:48 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-21 07:45:51 +0100
commit377ca8c3eb1e2a00e99bad29e013e499a1e03978 (patch)
treeba973fca714f850475006ffa3ddb666ffecfdc26 /app-admin
parentdev-python/boto3: Bump to 1.26.34 (diff)
downloadgentoo-377ca8c3eb1e2a00e99bad29e013e499a1e03978.tar.gz
gentoo-377ca8c3eb1e2a00e99bad29e013e499a1e03978.tar.bz2
gentoo-377ca8c3eb1e2a00e99bad29e013e499a1e03978.zip
app-admin/awscli: Bump to 1.27.34
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.27.34.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 6959c104ffec..d0a811419d64 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -3,3 +3,4 @@ DIST aws-cli-1.27.29.gh.tar.gz 2325759 BLAKE2B 693131da782ce248a00560617d3d1cd57
DIST aws-cli-1.27.31.gh.tar.gz 2327529 BLAKE2B 5c274358df6ed3081e945f21aac184fb774cc4b5d621954f4c4b88996252c3edb0b9c76d6aaab1f5273f0c2db1d19a7d5a46f3c1915190e7d5c141e9cfcf908d SHA512 37b295265d32e8ca73f3b16c4225027df8b735c39a930ad64db9590737da0e9407560fb82514417a0f7b42692fec27c8b949f91c973e719199c9767ff613559d
DIST aws-cli-1.27.32.gh.tar.gz 2328348 BLAKE2B 0958525a47f6dac8422dd37c9e099c2bf48d4bb5a8897673d18bb5b747dc6a0806d71cdf92899daf768ffa7cf9b7d39fe559cadad46eabc7913130d98c578d75 SHA512 db034e58761368a72e5a233e49e6c904281635fb47384f984b2ead1bd285bdb0af1a7e7b76d77ddaa6d19496ee1add756e1dbc43044aab1ba2b1f09232a112c9
DIST aws-cli-1.27.33.gh.tar.gz 2330168 BLAKE2B f5edc8494ba8b66c9819dd2b9182ab3bbc1f91c1114222e53ed890706c7d6c63adf31f754d85526c01459d3910b7cde5cb38f7e29c1821f086d3b94b9003eaec SHA512 d5e0e18804c7cbc549ba8d8cf4fa6a180f78f0681d09955e96874e0a67a3c3de2a1397995a62a9df14b08425feef6d625ae61522dbe38a62ddf9cb7e72d786d4
+DIST aws-cli-1.27.34.gh.tar.gz 2330530 BLAKE2B ee58a6cf4b2fa66c308a479222d13bdb1140e61c591c9d0bc452ae823a2d6a6ed14adb72cb6316d21ca26e33476fecf45f1484346924c9db2a4e7120d586babf SHA512 db9deda8021cb30f597f5bf96e0312bf3a0046da82a894663bb79549857b745e3676340997c0eb381e170d89e177d938cc1e93c0371b364bd23533dbdf39a344
diff --git a/app-admin/awscli/awscli-1.27.34.ebuild b/app-admin/awscli/awscli-1.27.34.ebuild
new file mode 100644
index 000000000000..caea725bbca7
--- /dev/null
+++ b/app-admin/awscli/awscli-1.27.34.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit bash-completion-r1 distutils-r1 multiprocessing
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.(y+2).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ tests/functional/eks/test_kubeconfig.py::TestKubeconfigLoader::test_load_simple
+ tests/unit/customizations/eks/test_update_kubeconfig.py::TestKubeconfigSelector::test_choose_env_only
+ tests/unit/customizations/eks/test_update_kubeconfig.py::TestKubeconfigSelector::test_choose_existing
+ tests/unit/customizations/eks/test_kubeconfig.py::TestKubeconfigValidator::test_valid
+ )
+
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)" --forked
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}