summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2024-10-03 14:48:43 +0200
committerAgostino Sarubbo <ago@gentoo.org>2024-10-03 14:48:43 +0200
commit693781c836e5f60550bb50678f19ab6b4ff5a15d (patch)
tree326c77b1e7adee1615c2a5965e978213ac63bdc0 /app-admin
parentmail-client/thunderbird-bin: drop 128.2.3 (diff)
downloadgentoo-693781c836e5f60550bb50678f19ab6b4ff5a15d.tar.gz
gentoo-693781c836e5f60550bb50678f19ab6b4ff5a15d.tar.bz2
gentoo-693781c836e5f60550bb50678f19ab6b4ff5a15d.zip
app-admin/exo: add 1.79.1
Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/exo/Manifest1
-rw-r--r--app-admin/exo/exo-1.79.1.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/app-admin/exo/Manifest b/app-admin/exo/Manifest
index 93f35d0f1a72..841e0269807a 100644
--- a/app-admin/exo/Manifest
+++ b/app-admin/exo/Manifest
@@ -1 +1,2 @@
DIST exo-1.79.0.gh.tar.gz 11129715 BLAKE2B b3f529429d448cb01b921ed1a192dfab04b396be7a0cc62152d9789369550b8aa65c1477192752a8a0943fa8e5d51518226e76a149cecd81c688633208e7f13b SHA512 e67236dde1c485578eeec50d439e6dc967bac444c4b9b84c390c6ce3546d18c65cafa3dc9b12e2bd0ca32714ddc5d0a2398dd9bf75777d302558778994d12b68
+DIST exo-1.79.1.gh.tar.gz 11133670 BLAKE2B ffaf536258b48604655a4b35b66b85a723161bc00be14b4637e955dde3dd557bf23e748729b27c6b4d4a44d38ecf43b00fa3c432f7116a926dbc064f9e25e861 SHA512 39bb0b3ed254fb26a08e1968728091c63806d3022cb97686600c5856e3afea3094662ce31e503037b2333cd6ad2a4e5bcbb697f63fe71fd5adac327c325090a2
diff --git a/app-admin/exo/exo-1.79.1.ebuild b/app-admin/exo/exo-1.79.1.ebuild
new file mode 100644
index 000000000000..43fbacd8aa32
--- /dev/null
+++ b/app-admin/exo/exo-1.79.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="Command-line tool for everything at Exoscale: compute, storage, dns"
+HOMEPAGE="https://github.com/exoscale/cli"
+SRC_URI="https://github.com/exoscale/cli/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+S="${WORKDIR}/cli-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND=">=dev-lang/go-1.16:="
+RESTRICT="strip"
+
+src_compile() {
+ ego build -mod vendor -o ${PN} -ldflags "-X main.version=${PVR}-gentoo -X main.commit="
+}
+
+src_test() {
+ # run at least 'exo version' for test
+ ./exo version > /dev/null 2>&1
+ if [[ $? -ne 0 ]]
+ then
+ die "Test failed"
+ fi
+}
+
+src_install() {
+ dobin ${PN}
+}