summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-09-18 08:07:04 +0200
committerMichał Górny <mgorny@gentoo.org>2018-09-18 08:18:56 +0200
commit9101d5de42e74ba7eaff612f3b751f247d664446 (patch)
tree0b5e0e97d1246efd0b415021a1e6e7286f65a0ad /app-admin
parentwww-apps/nanoc: add 4.9.5 (diff)
downloadgentoo-9101d5de42e74ba7eaff612f3b751f247d664446.tar.gz
gentoo-9101d5de42e74ba7eaff612f3b751f247d664446.tar.bz2
gentoo-9101d5de42e74ba7eaff612f3b751f247d664446.zip
app-admin/systemrescuecd-x86: Bump to 5.3.1
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/systemrescuecd-x86/Manifest1
-rw-r--r--app-admin/systemrescuecd-x86/systemrescuecd-x86-5.3.1.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/app-admin/systemrescuecd-x86/Manifest b/app-admin/systemrescuecd-x86/Manifest
index fa5fe331e43d..9edf7db35010 100644
--- a/app-admin/systemrescuecd-x86/Manifest
+++ b/app-admin/systemrescuecd-x86/Manifest
@@ -33,3 +33,4 @@ DIST systemrescuecd-x86-5.2.0.iso 569669632 BLAKE2B fe31a68df650b46bd875b91c643c
DIST systemrescuecd-x86-5.2.1.iso 570523648 BLAKE2B 9bb6b2ff7b9930f658baddbf60ef89e86171febcfb48eb0a6ce1bfea8fd3348773a9da948370f9f310dd0e992c40aa64a4ef1442f5cd7f408f847d147074cf1f SHA512 6820f079c9e97ac0d383ed9096a120e7e31771e1d41465f4cf7f5db36a7cb83ccfaae5c5e561181c3b3cb169d4cc4a9a6904a707ecde06a6de4f2456d2a658e4
DIST systemrescuecd-x86-5.2.2.iso 572006400 BLAKE2B 2cc95acc529ae8e0525664ffbdfefaf6e4513e8135fa6af120121b0b7930b0203bd17d5d70ccafacfe0064bb8615f45aa22b6e6e3fcee8a005a0315fd9b5cf62 SHA512 7dd1ccd63775e35f6589808416468c4a9314f4a7a5d0cb1f2bc34ffb9eef3a450b0da244dfc9e325d828c39404c0cdcce27cc990eade33762c17a1e32f8db9b5
DIST systemrescuecd-x86-5.3.0.iso 607547392 BLAKE2B 92aa82e54794adc1705111776b4df21bd39f96bdbed1c6e05bb24b01fd1a12d92fb1209241289f89adca7885fd441ddd61639d5168978b95dd0784faec65f32a SHA512 082a82a2882b62012944184107b2655de6c89f5a6c26145a3edb2b5a54ff6aad6a4ef43edc0468e62895daf4d5365d2722ffa8bf4f2f8e60f1ee7d9a727b013d
+DIST systemrescuecd-x86-5.3.1.iso 573913088 BLAKE2B 3c4da5777d05999e0b3e30b01dc821a4e840bb22d513fa4bfb9fdf601b9811676be8cee7ed9aae0aa7b971916add500b39172964384a2a07b3ed1cf5b946ba04 SHA512 1038622e148995450e61cd27f65af2ecb929ec8d0367fec3dbde01410a33596ec8f183d79ab931595c21deb597d60dae45ad516d8e1f00f32013729bdcd53ec8
diff --git a/app-admin/systemrescuecd-x86/systemrescuecd-x86-5.3.1.ebuild b/app-admin/systemrescuecd-x86/systemrescuecd-x86-5.3.1.ebuild
new file mode 100644
index 000000000000..7bfc35a7dd27
--- /dev/null
+++ b/app-admin/systemrescuecd-x86/systemrescuecd-x86-5.3.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="The .iso image of SystemRescueCD rescue disk, x86 (+ amd64) variant"
+HOMEPAGE="http://www.sysresccd.org/"
+# Large ISO mirroring explicitly approved by infra in bug #588766
+SRC_URI="mirror://sourceforge/systemrescuecd/sysresccd-${PN#*-}/${PV}/${P}.iso"
+
+LICENSE="GPL-2"
+SLOT="${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+isohybrid"
+
+DEPEND="isohybrid? ( >=sys-boot/syslinux-4 )"
+
+S=${WORKDIR}
+
+src_install() {
+ insinto "/usr/share/${PN%-*}"
+ doins "${DISTDIR}/${P}.iso"
+
+ if use isohybrid; then
+ set -- isohybrid -u "${ED}usr/share/${PN%-*}/${P}.iso"
+ echo "${@}"
+ "${@}" || die "${*} failed"
+ fi
+}
+
+pkg_postinst() {
+ local f=${EROOT%/}/usr/share/${PN%-*}/${PN}-newest.iso
+
+ # no version newer than ours? we're the newest!
+ if ! has_version ">${CATEGORY}/${PF}"; then
+ ln -f -s -v "${P}.iso" "${f}" || die
+ fi
+}
+
+pkg_postrm() {
+ local f=${EROOT%/}/usr/share/${PN%-*}/${PN}-newest.iso
+
+ # if there is no version newer than ours installed
+ if ! has_version ">${CATEGORY}/${PF}"; then
+ # and we are truly and completely uninstalled...
+ if [[ ! ${REPLACED_BY_VERSION} ]]; then
+ # then find an older version to set the symlink to
+ local newest_version=$(best_version "<${CATEGORY}/${PF}")
+
+ if [[ ${newest_version} ]]; then
+ # update the symlink
+ ln -f -s -v "${newest_version%-r*}.iso" "${f}" || die
+ else
+ # last version removed? clean up the symlink
+ rm -v "${f}" || die
+ # and the parent directory
+ rmdir "${f%/*}" || die
+ fi
+ fi
+ fi
+}