summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-06-09 10:21:04 +0200
committerHans de Graaff <graaff@gentoo.org>2023-06-09 10:21:17 +0200
commita0f040f21d95370f0b4fb9b2e9d8e55307f3a0af (patch)
tree4048b08282bd8e36d9b12eae2daf23fbc3b34133 /app-admin
parentdev-ruby/bunny: add 2.21.0 (diff)
downloadgentoo-a0f040f21d95370f0b4fb9b2e9d8e55307f3a0af.tar.gz
gentoo-a0f040f21d95370f0b4fb9b2e9d8e55307f3a0af.tar.bz2
gentoo-a0f040f21d95370f0b4fb9b2e9d8e55307f3a0af.zip
app-admin/puppet-lint: add 4.0.0
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/puppet-lint/Manifest1
-rw-r--r--app-admin/puppet-lint/puppet-lint-4.0.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/app-admin/puppet-lint/Manifest b/app-admin/puppet-lint/Manifest
index cc0209461070..2fe4c5621fae 100644
--- a/app-admin/puppet-lint/Manifest
+++ b/app-admin/puppet-lint/Manifest
@@ -1,2 +1,3 @@
DIST puppet-lint-2.5.2.gem 91136 BLAKE2B cae884b3994c7862f337a214903ecd4d7bb297e9e2bb7495fb94030304f53fa7ae98080b62944d5c96f2af0d208352d00030415a89259e8e188ec53da2a2b643 SHA512 996a5fda970c318a3f58a196c7b9aba7e712aae2b24d936b917f1dd9eb6bf5d706df28f70d88e1e174e175aabb13f1d22c8c90289314d5a1dd4ff9207ebbfe03
DIST puppet-lint-3.4.0.gem 83456 BLAKE2B fa6b274b3e6e84095fdaff6f024864dc301f0afc605198cc40b4dd8df7a9de66adfb91982195af9a0ad35301409c23e99d8d6ba5d3c43d3ee4dd57235de2b8cc SHA512 47c025ef925618cba3c1f579a3ef62bd5f9fd8ee7f8f9a68ed84daafeb7f9071e558619b24f0a249fcbe85d8c1b27e715938cc352792f9aa91de131820103e9c
+DIST puppet-lint-4.0.0.gem 80896 BLAKE2B 6e674deaec43c3b45e2c162ef3d09648bd3cdd589a3ae6ce92e21617633529705fe9999f4c6c361c3c1f041a3d25d1a03079f2f97705c01199253661bc9355dc SHA512 a23d316f60cb7d34c394bdaee0ad08070098d732210a92294a3d330cff7330aefe2be6bd9a60219d7538173c2f187c1ed427c6671a345f868286986164ea3a33
diff --git a/app-admin/puppet-lint/puppet-lint-4.0.0.ebuild b/app-admin/puppet-lint/puppet-lint-4.0.0.ebuild
new file mode 100644
index 000000000000..3925aec549db
--- /dev/null
+++ b/app-admin/puppet-lint/puppet-lint-4.0.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_BINWRAP="puppet-lint"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A linter for puppet DSL"
+HOMEPAGE="https://github.com/puppetlabs/puppet-lint"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+
+ruby_add_bdepend "test? (
+ dev-ruby/rspec-its:1
+ dev-ruby/rspec-collection_matchers:1
+ dev-ruby/rspec-json_expectations )"
+
+all_ruby_prepare() {
+ # Skip acceptance tests due to unpackages puppet_litmus which in turn
+ # has a number of unpackaged dependencies.
+ rm -rf spec/acceptance || die
+ rm -f spec/spec_helper_acceptance.rb || die
+}