summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2022-06-17 11:03:49 +0100
committerMarek Szuba <marecki@gentoo.org>2022-06-17 11:03:49 +0100
commitc209492f5d40f6c7919b11528d5b35801f116c22 (patch)
tree65cfbb313e69adc3fcc9c280f51697337f5606c2 /app-admin
parentsys-process/incron: make sure /etc/incron.d is kept (diff)
downloadgentoo-c209492f5d40f6c7919b11528d5b35801f116c22.tar.gz
gentoo-c209492f5d40f6c7919b11528d5b35801f116c22.tar.bz2
gentoo-c209492f5d40f6c7919b11528d5b35801f116c22.zip
app-admin/ansible-lint: add 6.3.0, drop 6.0.2
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/ansible-lint/Manifest2
-rw-r--r--app-admin/ansible-lint/ansible-lint-6.3.0.ebuild (renamed from app-admin/ansible-lint/ansible-lint-6.0.2.ebuild)13
2 files changed, 9 insertions, 6 deletions
diff --git a/app-admin/ansible-lint/Manifest b/app-admin/ansible-lint/Manifest
index 323dba7e4140..cc62ee1d1a12 100644
--- a/app-admin/ansible-lint/Manifest
+++ b/app-admin/ansible-lint/Manifest
@@ -1,3 +1,3 @@
DIST ansible-lint-5.4.0.tar.gz 349353 BLAKE2B 9f41abdf1e9485afa4c8ed9498627b0dcbdcf57916f3b57c9886de8bd806e4e5b34e7e9c2e66b44ac8009a0afcea4d8566900ee8d391eaca61081fa23323c41c SHA512 f1bbbb49eb77991d60b6087646c695a938d328d719bba67707af4ed858de857d383b78490bcf0930cffebd13a0b0abde20269a47e47e4713a37da715a28c5da0
-DIST ansible-lint-6.0.2.tar.gz 195044 BLAKE2B 3334049dd1dc05444c6c362601da8d7e808c6b3473e87613b8892651cecb76058cb0aa370aa5d00cf6bc76ee3b096480fdce52facee4f043c01d6c76084860ba SHA512 a47e79c59dfcf3e36654247bd206581798f2559261142e3943b60e0688d75b5a6332832a9f9127f99b2faa6afff959a33c55fbc80aa5881f064725998420f679
DIST ansible-lint-6.2.2.tar.gz 232952 BLAKE2B 571dce6dc348c1158fed396fc29054421d172964facd8cbb0f8c1560036de574aa304f59497c8c76415ac99424d0450c8b06509ced113c9a997808e960793621 SHA512 ae119b29d87ce59e7bd5c401a8fcbc2194bdddecd5a65010ea02aee62cff1764a767803a57edcfd297e9ad0cbdf70fe69212625ed80b21afb53b4ebe429a7636
+DIST ansible-lint-6.3.0.tar.gz 268331 BLAKE2B 00ea2dbc7bb5e71d63a737ac99d4116441f6b1eee2fa476d9aa4d78068064e53975df00950f337e7c9e25dacf8778ddd2e40eb5d3ea1301f56a80dfd90d42c20 SHA512 3e9d480cb90f3022a4b001c061c3e76b753620776a009b1563dce335c13ee38b7ac334725592ac644a2808d85ceb98b618a451c193bc7c4961474d4e7fbbb88e
diff --git a/app-admin/ansible-lint/ansible-lint-6.0.2.ebuild b/app-admin/ansible-lint/ansible-lint-6.3.0.ebuild
index e8d11233f9d4..6a378c69fa29 100644
--- a/app-admin/ansible-lint/ansible-lint-6.0.2.ebuild
+++ b/app-admin/ansible-lint/ansible-lint-6.3.0.ebuild
@@ -17,15 +17,17 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~riscv"
-# As of 6.0.2, access to Ansible Galaxy (i.e. the Internet) is required even to get
-# the test suite started (Bug #836582). TODO: Talk to upstream about how to bypass this.
+# Since 6.2.0 ansible-lint once again does not need access to Ansible Galaxy
+# even to get the test suite started, however quite a large fraction of tests
+# fails without network access. Needs more work.
PROPERTIES="test_network"
RESTRICT="test"
RDEPEND="
>=app-admin/ansible-base-2.12.0[${PYTHON_USEDEP}]
- >=dev-python/ansible-compat-2.0.2[${PYTHON_USEDEP}]
+ >=dev-python/ansible-compat-2.1.0[${PYTHON_USEDEP}]
>=dev-python/enrich-1.2.6[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-4.6.0[${PYTHON_USEDEP}]
dev-python/packaging[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]
>=dev-python/rich-9.5.1[${PYTHON_USEDEP}]
@@ -37,6 +39,7 @@ BDEPEND="
>=dev-python/setuptools_scm_git_archive-1.0[${PYTHON_USEDEP}]
test? (
>=dev-python/flaky-3.7.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-plus-0.2[${PYTHON_USEDEP}]
>=dev-python/pytest-xdist-2.5.0[${PYTHON_USEDEP}]
)"
@@ -44,7 +47,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-6.0.2_test-module-check.patch
)
-# Skip problematic tests:
+# Skip problematic tests (TODO: update this list for ansible-lint-6.2.0+):
# - test_call_from_outside_venv doesn't play nicely with the sandbox
# - all test_eco and some test_prerun tests require Internet access
# - as of 5.4.0, test_cli_auto_detect fails even when run manually with tox
@@ -61,7 +64,7 @@ EPYTEST_DESELECT=(
distutils_enable_tests pytest
python_test() {
- # As of 6.0.2, without this the test suite gets confused by the presence of ansible-lint modules
+ # As of 6.2.1, without this the test suite still gets confused by the presence of ansible-lint modules
# in both ${ED} and ${S}.
cd "${S}" || die