summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Raschbacher <lordvan@gentoo.org>2023-05-07 10:20:12 +0200
committerThomas Raschbacher <lordvan@gentoo.org>2023-05-07 10:20:45 +0200
commit5528c104da2f3d92944ea63839603e691049b8c6 (patch)
tree6123a70e7ce312dc978d3eb84717a8e22eb93ddb /app-arch/alien/alien-8.95.6.ebuild
parentsci-libs/metis: ensure GKlib is marked as NEEDED (diff)
downloadgentoo-5528c104da2f3d92944ea63839603e691049b8c6.tar.gz
gentoo-5528c104da2f3d92944ea63839603e691049b8c6.tar.bz2
gentoo-5528c104da2f3d92944ea63839603e691049b8c6.zip
app-arch/alien: add 8.95.6
Signed-off-by: Thomas Raschbacher <lordvan@gentoo.org>
Diffstat (limited to 'app-arch/alien/alien-8.95.6.ebuild')
-rw-r--r--app-arch/alien/alien-8.95.6.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-arch/alien/alien-8.95.6.ebuild b/app-arch/alien/alien-8.95.6.ebuild
new file mode 100644
index 000000000000..f2d6dfad91e1
--- /dev/null
+++ b/app-arch/alien/alien-8.95.6.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit perl-module
+
+DESCRIPTION="Converts between the rpm, dpkg, stampede slp, and slackware tgz file formats"
+HOMEPAGE="https://sourceforge.net/projects/alien-pkg-convert"
+SRC_URI="mirror://debian/pool/main/a/${PN}/${PN}_${PV}.tar.xz -> ${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+bzip2"
+
+RDEPEND="
+ app-arch/rpm
+ app-arch/dpkg
+ dev-util/debhelper
+ >=app-arch/tar-1.14.91
+ bzip2? ( app-arch/bzip2 )"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-8.95-tar-extensions.patch" )