summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-11-14 16:04:11 +0100
committerDavid Seifert <soap@gentoo.org>2020-11-14 16:04:11 +0100
commitf458767ff165e37e17b0dd794bc32ef5dd8886be (patch)
treea9b97bf8245fec18a29ef3c4dcfd8f016778c3b2 /app-arch/gtk-splitter/gtk-splitter-2.2.1-r2.ebuild
parentapp-arch/tarsync: Port to EAPI 7 (diff)
downloadgentoo-f458767ff165e37e17b0dd794bc32ef5dd8886be.tar.gz
gentoo-f458767ff165e37e17b0dd794bc32ef5dd8886be.tar.bz2
gentoo-f458767ff165e37e17b0dd794bc32ef5dd8886be.zip
app-arch/gtk-splitter: Port to EAPI 7
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-arch/gtk-splitter/gtk-splitter-2.2.1-r2.ebuild')
-rw-r--r--app-arch/gtk-splitter/gtk-splitter-2.2.1-r2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-arch/gtk-splitter/gtk-splitter-2.2.1-r2.ebuild b/app-arch/gtk-splitter/gtk-splitter-2.2.1-r2.ebuild
new file mode 100644
index 000000000000..288cc392ddae
--- /dev/null
+++ b/app-arch/gtk-splitter/gtk-splitter-2.2.1-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Split files into smaller pieces and combine them back together"
+HOMEPAGE="http://gtk-splitter.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="crypt"
+
+RDEPEND="
+ x11-libs/gtk+:2
+ virtual/libintl:0
+ crypt? ( >=app-crypt/mhash-0.8:0 )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${P}-r1-desktop-QA-fixes.patch )
+
+src_configure() {
+ default
+
+ if ! use crypt ; then
+ # configure script only autodetects
+ sed -i -e 's:-lmhash::' -e 's:-DHAVE_LIBMHASH=1::' src/Makefile || die
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" docdir="${EPREFIX}/usr/share/doc/${PF}" install
+}