summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-08-13 22:04:03 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-08-13 22:06:13 +0300
commit8ba25aadaa41017f95fc29abe2513a3bd4ee9372 (patch)
tree4dc67905752a209ee8e76129b9b862e870672209 /app-arch
parentnet-im/discord: add 0.0.64, drop 0.0.63 (diff)
downloadgentoo-8ba25aadaa41017f95fc29abe2513a3bd4ee9372.tar.gz
gentoo-8ba25aadaa41017f95fc29abe2513a3bd4ee9372.tar.bz2
gentoo-8ba25aadaa41017f95fc29abe2513a3bd4ee9372.zip
app-arch/alien: add 8.95.7
Closes: https://bugs.gentoo.org/707586 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/alien/Manifest1
-rw-r--r--app-arch/alien/alien-8.95.7.ebuild29
-rw-r--r--app-arch/alien/files/alien-8.95-rpm-zstd.patch36
-rw-r--r--app-arch/alien/files/alien-8.95-tar-extensions.patch6
4 files changed, 66 insertions, 6 deletions
diff --git a/app-arch/alien/Manifest b/app-arch/alien/Manifest
index 8dcb3ef90dc6..3586f1bc6f33 100644
--- a/app-arch/alien/Manifest
+++ b/app-arch/alien/Manifest
@@ -1,2 +1,3 @@
DIST alien-8.95.6.tar.xz 58088 BLAKE2B 5b7467552856d809fc1b43af7de905d7f52629799bfd01dfb7ab61dfbd1c27e0f6f6b8364aa03a925cc6bea74616bf497f4fd195c637d6d1bcd7847a17ab5ccd SHA512 29ed80f249b38b47a26ee9d058d057be8728d18d771c1f847919f296d2c8359fcc33a32912749f2ed77b1214e61f101b75960a82cbd3d76bbb7f205acfd4f152
+DIST alien-8.95.7.tar.xz 58236 BLAKE2B 18728dfc63f08ca78e3063f2b68bcdbdc516015a8c55c13e29999934830308440907d7a1298acd4c41aa2a601d9a8cd3148880a51235769012dbafb8e91e9c82 SHA512 5528ee66117d5429b2021350c11fcaa1e831c8f46dfb661c7ec42e2840c67d7fa488dabb7361e91fc034ba6b8a970938ec08e74ab619747e03acb577213d27f8
DIST alien-8.95.tar.xz 56940 BLAKE2B c2f6b71d39800a7bc4ab00bcd50d165855bad4eb1a17fe217aeb302c6b7af701bcd9445276d7e522db7e6c81f1e8d7e9e2ada99f9d7505e6ec958ae87df7c9f7 SHA512 c46d3c82542dc3d96eeabea0f0c7ab5b572acaf67d15e2064ea01df32d69a2cf6e083754be49269df6cd7431ec5b3e09ddcb83fbe2ee17843b22e9cd3e73073c
diff --git a/app-arch/alien/alien-8.95.7.ebuild b/app-arch/alien/alien-8.95.7.ebuild
new file mode 100644
index 000000000000..653dba8fe3d1
--- /dev/null
+++ b/app-arch/alien/alien-8.95.7.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit perl-module
+
+DESCRIPTION="Converts between the rpm, dpkg, stampede slp, and slackware tgz file formats"
+HOMEPAGE="https://sourceforge.net/projects/alien-pkg-convert/"
+SRC_URI="mirror://debian/pool/main/a/${PN}/${PN}_${PV}.tar.xz -> ${P}.tar.xz"
+S=${WORKDIR}/${PN}
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+bzip2"
+
+RDEPEND="
+ app-arch/rpm
+ app-arch/dpkg
+ dev-util/debhelper
+ >=app-arch/tar-1.14.91
+ bzip2? ( app-arch/bzip2 )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-8.95-tar-extensions.patch"
+ "${FILESDIR}/${PN}-8.95-rpm-zstd.patch"
+)
diff --git a/app-arch/alien/files/alien-8.95-rpm-zstd.patch b/app-arch/alien/files/alien-8.95-rpm-zstd.patch
new file mode 100644
index 000000000000..89e2ce31e57b
--- /dev/null
+++ b/app-arch/alien/files/alien-8.95-rpm-zstd.patch
@@ -0,0 +1,36 @@
+From 08e8768b07065b32e1aa9ccb3adae79a157bbfbc Mon Sep 17 00:00:00 2001
+From: Lars Kellogg-Stedman <lars@oddbit.com>
+Date: Tue, 13 Aug 2024 22:02:30 +0300
+Subject: [PATCH] Add support for decompressing zstd rpm payloads
+
+Recent (Fedora 32 and later) versions of Fedora have switched to
+using zstd to compress rpm payloads.
+
+https://bugs.debian.org/518348
+--- a/Alien/Package/Rpm.pm
++++ b/Alien/Package/Rpm.pm
+@@ -159,9 +159,19 @@ sub unpack {
+ $this->SUPER::unpack(@_);
+ my $workdir=$this->unpacked_tree;
+
+- # Check if we need to use lzma to uncompress the cpio archive
++ # Check if we need to uncompress the cpio archive
+ my $decomp='';
+- if ($this->do("rpm2cpio '".$this->filename."' | lzma -t -q > /dev/null 2>&1")) {
++ if ($this->do("rpm2cpio '".$this->filename."' | xz -t -q > /dev/null 2>&1")) {
++ # we first check xz (previously lzma) because this is the
++ # most common compression type at the moment.
++ $decomp = 'xz -d -q |';
++ } elsif ($this->do("rpm2cpio '".$this->filename."' | zstd -t -q > /dev/null 2>&1")) {
++ # we next check zstd, which is used by newer (Fedora 32 and later)
++ # rpms.
++ $decomp = 'zstd -d -q |';
++ } elsif ($this->do("rpm2cpio '".$this->filename."' | lzma -t -q > /dev/null 2>&1")) {
++ # We check lzma last in case we're on an older system with
++ # only lzma and no xz
+ $decomp = 'lzma -d -q |';
+ }
+
+--
+2.45.2
+
diff --git a/app-arch/alien/files/alien-8.95-tar-extensions.patch b/app-arch/alien/files/alien-8.95-tar-extensions.patch
index 4709fcc1c4f8..29ec9a72f94a 100644
--- a/app-arch/alien/files/alien-8.95-tar-extensions.patch
+++ b/app-arch/alien/files/alien-8.95-tar-extensions.patch
@@ -4,12 +4,6 @@ Date: Fri, 1 Sep 2017 02:20:37 -0500
Subject: [PATCH] add more tar extensions
Signed-off-by: Austin English <austinenglish@gmail.com>
----
- Alien/Package/Tgz.pm | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/Alien/Package/Tgz.pm b/Alien/Package/Tgz.pm
-index 7ab6e8b..65a3d2d 100644
--- a/Alien/Package/Tgz.pm
+++ b/Alien/Package/Tgz.pm
@@ -11,7 +11,7 @@ use strict;