summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlice Ferrazzi <alicef@gentoo.org>2021-09-17 23:45:21 +0900
committerAlice Ferrazzi <alicef@gentoo.org>2021-09-17 23:45:46 +0900
commit65759cecc711840bdce4dba979e2e9094706a56b (patch)
treeab2baa9a24b1798b72f6574faee5f57fabcd37b1 /app-benchmarks/tiobench/tiobench-0.5.0.ebuild
parentdev-python/rencode: drop 1.0.6-r1 (diff)
downloadgentoo-65759cecc711840bdce4dba979e2e9094706a56b.tar.gz
gentoo-65759cecc711840bdce4dba979e2e9094706a56b.tar.bz2
gentoo-65759cecc711840bdce4dba979e2e9094706a56b.zip
app-benchmarks/tiobench: bump to v0.5.0
Package-Manager: Portage-3.0.19, Repoman-3.0.3 Signed-off-by: Alice Ferrazzi <alicef@gentoo.org>
Diffstat (limited to 'app-benchmarks/tiobench/tiobench-0.5.0.ebuild')
-rw-r--r--app-benchmarks/tiobench/tiobench-0.5.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-benchmarks/tiobench/tiobench-0.5.0.ebuild b/app-benchmarks/tiobench/tiobench-0.5.0.ebuild
new file mode 100644
index 000000000000..fdccf6c88e2f
--- /dev/null
+++ b/app-benchmarks/tiobench/tiobench-0.5.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Portable, robust, fully-threaded I/O benchmark program"
+HOMEPAGE="https://github.com/aliceinwire/tiobench"
+SRC_URI="https://github.com/aliceinwire/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/perl"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ sed -i \
+ -e "s:/usr/local/bin:${EPREFIX}/usr/sbin:" tiobench.pl \
+ || die "sed tiobench.pl failed"
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ LINK="$(tc-getCC)" \
+ DEFINES="-DLARGEFILES" \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dosbin tiotest tiobench.pl scripts/tiosum.pl
+ einstalldocs
+}