summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2024-07-06 15:28:56 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2024-07-06 15:29:19 +0200
commit6ff37b45dda5068d4f6e9ef772367de3dce884e0 (patch)
treee318e54b6acb87eac9298d3ed3c55b0c2d0fa05a /app-cdr
parentnet-misc/smb4k: Keyword 3.2.72 riscv, #934361 (diff)
downloadgentoo-6ff37b45dda5068d4f6e9ef772367de3dce884e0.tar.gz
gentoo-6ff37b45dda5068d4f6e9ef772367de3dce884e0.tar.bz2
gentoo-6ff37b45dda5068d4f6e9ef772367de3dce884e0.zip
app-cdr/brasero: fixed incompatible pointers + sorted vars
Closes: https://bugs.gentoo.org/919078 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'app-cdr')
-rw-r--r--app-cdr/brasero/brasero-3.12.3.ebuild6
-rw-r--r--app-cdr/brasero/files/brasero-3.12.3-incompatible-pointers.patch22
2 files changed, 27 insertions, 1 deletions
diff --git a/app-cdr/brasero/brasero-3.12.3.ebuild b/app-cdr/brasero/brasero-3.12.3.ebuild
index ad5a76453344..402c35fd9bdd 100644
--- a/app-cdr/brasero/brasero-3.12.3.ebuild
+++ b/app-cdr/brasero/brasero-3.12.3.ebuild
@@ -11,8 +11,8 @@ HOMEPAGE="https://wiki.gnome.org/Apps/Brasero"
LICENSE="GPL-2+ CC-BY-SA-3.0"
SLOT="0/3.1" # subslot is 3.suffix of libbrasero-burn3
-IUSE="+css +introspection +libburn mp3 nautilus playlist tracker"
KEYWORDS="amd64 ~arm arm64 ~loong ppc ppc64 ~riscv x86"
+IUSE="+css +introspection +libburn mp3 nautilus playlist tracker"
DEPEND="
>=dev-libs/glib-2.29.14:2
@@ -58,6 +58,10 @@ BDEPEND="
PDEPEND="gnome-base/gvfs"
+PATCHES=(
+ "${FILESDIR}/${P}-incompatible-pointers.patch"
+)
+
src_configure() {
gnome2_src_configure \
--disable-caches \
diff --git a/app-cdr/brasero/files/brasero-3.12.3-incompatible-pointers.patch b/app-cdr/brasero/files/brasero-3.12.3-incompatible-pointers.patch
new file mode 100644
index 000000000000..edfdb8786cd9
--- /dev/null
+++ b/app-cdr/brasero/files/brasero-3.12.3-incompatible-pointers.patch
@@ -0,0 +1,22 @@
+--- a/libbrasero-burn/brasero-drive-properties.c
++++ b/libbrasero-burn/brasero-drive-properties.c
+@@ -844,7 +844,7 @@ brasero_drive_properties_set_property (GObject *object,
+ /* NOTE: no need to unref a potential previous session since
+ * it's only set at construct time */
+ session = g_value_get_object (value);
+- priv->session = g_object_ref (session);
++ priv->session = (BraseroSessionCfg *)g_object_ref (session);
+
+ brasero_drive_properties_update (BRASERO_DRIVE_PROPERTIES (object));
+ priv->valid_sig = g_signal_connect (session,
+--- a/libbrasero-utils/brasero-metadata.c
++++ b/libbrasero-utils/brasero-metadata.c
+@@ -665,7 +665,7 @@ brasero_metadata_install_missing_plugins (BraseroMetadata *self)
+
+ context = gst_install_plugins_context_new ();
+ gst_install_plugins_context_set_xid (context, brasero_metadata_get_xid (self));
+- status = gst_install_plugins_async ((gchar **) details->pdata,
++ status = gst_install_plugins_async ((const gchar * const *) details->pdata,
+ context,
+ brasero_metadata_install_plugins_result,
+ downloads);