summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-09 03:43:49 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-09 04:10:25 +0200
commitbb1d24efe80554d3a9731306805ba7d82b214de4 (patch)
treed7fd191a0556dc419a5fbc5a192ce117a0953c0e /app-cdr
parentdev-libs/libmirage: Bump to 3.2.8 (diff)
downloadgentoo-bb1d24efe80554d3a9731306805ba7d82b214de4.tar.gz
gentoo-bb1d24efe80554d3a9731306805ba7d82b214de4.tar.bz2
gentoo-bb1d24efe80554d3a9731306805ba7d82b214de4.zip
app-cdr/cdemu-daemon: Bump to 3.2.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-cdr')
-rw-r--r--app-cdr/cdemu-daemon/Manifest1
-rw-r--r--app-cdr/cdemu-daemon/cdemu-daemon-3.2.7.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/app-cdr/cdemu-daemon/Manifest b/app-cdr/cdemu-daemon/Manifest
index 874b9b64283f..52a6b241660f 100644
--- a/app-cdr/cdemu-daemon/Manifest
+++ b/app-cdr/cdemu-daemon/Manifest
@@ -1 +1,2 @@
DIST cdemu-daemon-3.2.6.tar.xz 85976 BLAKE2B 33d03324fbc222674967f1d6b93c2bf1793528948cfce1089dbdfe799d3b40eaabae2e3f62b4696eba020f04c192e9d458a91e8bdd85465e00ec5a84194982e0 SHA512 cead8e4f7e0eec6e1284924cfe88cdfb78ec9f0769ffa423cd1801261540b3806a9704b6abbddc175e9e7d1aeef2acb9889b36ed13d89fd4b9dcda91fe1a08ca
+DIST cdemu-daemon-3.2.7.tar.xz 86140 BLAKE2B 09e968636bb95b0cb205a94769e2ba278f66199bb23c6db0f2860fa621f33bb37b6e55028dabec98a6fc7cf6aded42a1bb8d153381110bf38b678a74a2b5c8db SHA512 c09ae0e32526c85b6bb001a5cf8c11ed3662390e16fad8c07e5cded7febe4c586e8c677c85340fb20e321dfc3621e15b4a4220606147adc14ab969d6924778aa
diff --git a/app-cdr/cdemu-daemon/cdemu-daemon-3.2.7.ebuild b/app-cdr/cdemu-daemon/cdemu-daemon-3.2.7.ebuild
new file mode 100644
index 000000000000..225e87f3eea2
--- /dev/null
+++ b/app-cdr/cdemu-daemon/cdemu-daemon-3.2.7.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake systemd
+
+DESCRIPTION="Daemon of the CDEmu optical media image mounting suite"
+HOMEPAGE="https://cdemu.sourceforge.io"
+SRC_URI="https://download.sourceforge.net/cdemu/cdemu-daemon/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0/7" # subslot = CDEMU_DAEMON_INTERFACE_VERSION_MAJOR in CMakeLists.txt
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ >=dev-libs/glib-2.38:2
+ >=dev-libs/libmirage-3.2.0:=
+ >=media-libs/libao-0.8.0:=
+"
+RDEPEND="
+ ${DEPEND}
+ sys-apps/dbus
+ >=sys-fs/vhba-20130607
+"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+DOCS=( AUTHORS README )
+
+src_install() {
+ cmake_src_install
+
+ insinto /etc/modules-load.d
+ newins - vhba.conf <<<"vhba"
+ systemd_douserunit service-example/cdemu-daemon.service
+ insinto /usr/share/dbus-1/services
+ doins service-example/net.sf.cdemu.CDEmuDaemon.service
+}
+
+pkg_postinst() {
+ elog "As of 3.2.5, cdemu-daemon no longer supports autoloading"
+ elog "on non-systemd systems. OpenRC users have to start it manually."
+ elog
+ elog "We install /etc/modules-load.d/vhba.conf to load the module"
+ elog "automatically, and D-BUS autolaunch will start cdemu-daemon user"
+ elog "service."
+}