summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-11-23 14:59:21 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-11-23 16:11:57 +0100
commit7b259d60652e7f31e1d78b57c5c3917b8a7ca1b7 (patch)
treed1d99274a8f2fb6d38270bcbd88f55c1b0234827 /app-containers/devcontainer
parentapp-emacs/helm: bump to 3.9.6 (diff)
downloadgentoo-7b259d60652e7f31e1d78b57c5c3917b8a7ca1b7.tar.gz
gentoo-7b259d60652e7f31e1d78b57c5c3917b8a7ca1b7.tar.bz2
gentoo-7b259d60652e7f31e1d78b57c5c3917b8a7ca1b7.zip
app-containers/devcontainer: bump to 0.54.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-containers/devcontainer')
-rw-r--r--app-containers/devcontainer/Manifest1
-rw-r--r--app-containers/devcontainer/devcontainer-0.54.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/app-containers/devcontainer/Manifest b/app-containers/devcontainer/Manifest
index 9bc8fc707544..4b5c1f198026 100644
--- a/app-containers/devcontainer/Manifest
+++ b/app-containers/devcontainer/Manifest
@@ -1,2 +1,3 @@
DIST devcontainer-0.52.1.tgz 614268 BLAKE2B e1e2979e7d105e0082db4019260b7015c6bab9899f43e75ff1246f879bd659557404ca2f10ffa021bd5cf2caaff6f0dad53ca8b8c48e7f082d00961c9982faf0 SHA512 b182b57071c356374121dc63301f0eebaf3ea9fd0000424f31b78c47d6536d4cd74013647bcf2f50e67a0c3f528eca9e1397acf12a565fa8d5ea0688b73245c8
DIST devcontainer-0.53.0.tgz 614575 BLAKE2B b7279b629cae49da39eca9defa17055b94c95db8ed79f78ec869f15a361ae12b4142817433e789c0d1231a753a1c7cc0247d5de738981f0f17c61de82aa7a8c9 SHA512 942e3b4b4ab19de876f22fcad16a1b41e5edc271cafcbc3281f198a80156e44ea94217cfcb4e0ef63ca96e6e854e030f4f70a51e7bcc655f0cb8cf23dcf003dc
+DIST devcontainer-0.54.0.tgz 603716 BLAKE2B fc3853f69b88c8d31b5bce463e9ca4e393e6084286f9f3ffc504c1bff27f90e276168ac09f42354dc1498c98ac8336ee4b85dd5605d10c7f31d156ea2f33a95b SHA512 197bfe938d31280a27c02091ac9a5288b70993e305290444fcb11886f03c81899391ca7797e532469764e54fcc3dfc93ba73f306a3f4a08d5e8b6bf38609f456
diff --git a/app-containers/devcontainer/devcontainer-0.54.0.ebuild b/app-containers/devcontainer/devcontainer-0.54.0.ebuild
new file mode 100644
index 000000000000..399665b46cde
--- /dev/null
+++ b/app-containers/devcontainer/devcontainer-0.54.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Reference implementation of the Development Containers specification"
+HOMEPAGE="https://containers.dev/
+ https://github.com/devcontainers/cli/"
+SRC_URI="https://registry.npmjs.org/@devcontainers/cli/-/cli-${PV}.tgz
+ -> ${P}.tgz"
+S="${WORKDIR}/package"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ net-libs/nodejs
+"
+BDEPEND="
+ >=net-libs/nodejs-16[npm]
+"
+
+DOCS=( CHANGELOG.md README.md )
+
+src_compile() {
+ # Skip, nothing to compile here.
+ :
+}
+
+src_install() {
+ local -a my_npm_opts=(
+ --audit false
+ --color false
+ --foreground-scripts
+ --global
+ --offline
+ --omit dev
+ --prefix "${ED}/usr"
+ --progress false
+ --verbose
+ )
+ npm "${my_npm_opts[@]}" install "${DISTDIR}/${P}.tgz" || die "npm install failed"
+
+ einstalldocs
+}