summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-crypt/efitools/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-crypt/efitools/files')
-rw-r--r--app-crypt/efitools/files/xxdi.patch110
1 files changed, 110 insertions, 0 deletions
diff --git a/app-crypt/efitools/files/xxdi.patch b/app-crypt/efitools/files/xxdi.patch
new file mode 100644
index 000000000000..ec62125ea4ad
--- /dev/null
+++ b/app-crypt/efitools/files/xxdi.patch
@@ -0,0 +1,110 @@
+From gregkh@linuxfoundation.org Sun Sep 1 14:55:47 2013
+Date: Sun, 1 Sep 2013 14:58:15 -0700
+From: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
+To: James Bottomley <James.Bottomley@HansenPartnership.com>
+Cc: JBottomley@Parallels.com, greg@kroah.com
+Subject: [efitools PATCH] Makefile/Make.rules: don't rely on vim-core
+Message-ID: <20130901215815.GA8749@kroah.com>
+
+From: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
+
+Subject: Makefile/Make.rules: don't rely on vim-core
+
+This adds the xxdi.pl script to replace the call to 'xxd -i', removing a
+build dependancy on vim-core, which some distros don't really want to
+have (i.e. Gentoo and its build derivatives like ChromeOS and CoreOS.)
+
+Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
+---
+ Make.rules | 2 +-
+ Makefile | 2 +-
+ xxdi.pl | 50 ++++++++++++++++++++++++++++++++++++++++++++++++++
+ 3 files changed, 52 insertions(+), 2 deletions(-)
+ create mode 100755 xxdi.pl
+
+diff --git a/Make.rules b/Make.rules
+index 419b3b9..309b231 100644
+--- a/Make.rules
++++ b/Make.rules
+@@ -38,7 +38,7 @@ endif
+ nm -D $@ | grep ' U ' && exit 1 || exit 0
+
+ %.h: %.auth
+- xxd -i $< > $@
++ ./xxdi.pl $< > $@
+
+ %.hash: %.efi hash-to-efi-sig-list
+ ./hash-to-efi-sig-list $< $@
+diff --git a/Makefile b/Makefile
+index 52f4551..a39cafe 100644
+--- a/Makefile
++++ b/Makefile
+@@ -62,7 +62,7 @@ DB.auth: DB.esl KEK.crt sign-efi-sig-list
+
+ hashlist.h: HashTool.hash
+ cat $^ > /tmp/tmp.hash
+- xxd -i /tmp/tmp.hash > $@
++ ./xxdi.pl /tmp/tmp.hash > $@
+ rm -f /tmp/tmp.hash
+
+
+diff --git a/xxdi.pl b/xxdi.pl
+new file mode 100755
+index 0000000..acc974c
+--- /dev/null
++++ b/xxdi.pl
+@@ -0,0 +1,50 @@
++#!/usr/bin/env perl
++#
++# xxdi.pl - perl implementation of 'xxd -i' mode
++#
++# Copyright 2013 Greg Kroah-Hartman <gregkh@linuxfoundation.org>
++# Copyright 2013 Linux Foundation
++#
++# Released under the GPLv2.
++#
++# Implements the "basic" functionality of 'xxd -i' in perl to keep build
++# systems from having to build/install/rely on vim-core, which not all
++# distros want to do. But everyone has perl, so use it instead.
++#
++
++use strict;
++use warnings;
++use File::Slurp qw(slurp);
++
++my $indata = slurp(@ARGV ? $ARGV[0] : \*STDIN);
++my $len_data = length($indata);
++my $num_digits_per_line = 12;
++my $var_name;
++my $outdata;
++
++# Use the variable name of the file we read from, converting '/' and '.
++# to '_', or, if this is stdin, just use "stdin" as the name.
++if (@ARGV) {
++ $var_name = $ARGV[0];
++ $var_name =~ s/\//_/g;
++ $var_name =~ s/\./_/g;
++} else {
++ $var_name = "stdin";
++}
++
++$outdata .= "unsigned char $var_name\[] = {";
++
++# trailing ',' is acceptable, so instead of duplicating the logic for
++# just the last character, live with the extra ','.
++for (my $key= 0; $key < $len_data; $key++) {
++ if ($key % $num_digits_per_line == 0) {
++ $outdata .= "\n\t";
++ }
++ $outdata .= sprintf("0x%.2x, ", ord(substr($indata, $key, 1)));
++}
++
++$outdata .= "\n};\nunsigned int $var_name\_len = $len_data;\n";
++
++binmode STDOUT;
++print {*STDOUT} $outdata;
++
+--
+1.8.4.6.g82e253f.dirty
+
+