summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-editors/fb2edit
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-editors/fb2edit')
-rw-r--r--app-editors/fb2edit/Manifest2
-rw-r--r--app-editors/fb2edit/fb2edit-0.0.8.ebuild32
-rw-r--r--app-editors/fb2edit/fb2edit-0.0.9.ebuild34
-rw-r--r--app-editors/fb2edit/files/fb2edit-0.0.9-fix-compiler-warnings.patch101
-rw-r--r--app-editors/fb2edit/metadata.xml15
5 files changed, 184 insertions, 0 deletions
diff --git a/app-editors/fb2edit/Manifest b/app-editors/fb2edit/Manifest
new file mode 100644
index 000000000000..0f480edf8def
--- /dev/null
+++ b/app-editors/fb2edit/Manifest
@@ -0,0 +1,2 @@
+DIST fb2edit-0.0.8.tar.bz2 222684 SHA256 f6f6fe21fb8651f8aaff12bfd923257dab17e64a47557669a2ad93ce22c8ed89 SHA512 05b79c5c7965af410fda335fc6fe2612f541c8bae6241c115affdd33b9375bba5710e689933f1745dbf2c132896a843e532bf62c079f0d646f97bedd0e81a572 WHIRLPOOL 993558bdab1a66295c5189e1c05886caa3e590a9779be876ad6d6f46b11958ff53e2e3db50c018ee63c20e9b2108308c03eb5b5a83f54badf93d99f16b94d1e0
+DIST fb2edit-0.0.9.tar.gz 242568 SHA256 6d64fe1597911170d6d6d59d4b36d406a9389a37c2ef5c68051176bf6f45f181 SHA512 a51eb9e7c7f70d55dc1eb06f4f7e03a031ce229570ee9620f6299cac6c2b435c8bcd702def7a50783055c066227d77b5c235f2bba231b328831b4666cc0f61b9 WHIRLPOOL 2f4ab29352318211c36fe1bfd739d69633f31ec0ce0c0a2edf4dac7965896074900f8c5b840943d900a5ff12d6cc3a819a19f7ea77201465446f17dcc9aba8cb
diff --git a/app-editors/fb2edit/fb2edit-0.0.8.ebuild b/app-editors/fb2edit/fb2edit-0.0.8.ebuild
new file mode 100644
index 000000000000..4488bb484a26
--- /dev/null
+++ b/app-editors/fb2edit/fb2edit-0.0.8.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="a WYSIWYG FictionBook (fb2) editor"
+HOMEPAGE="http://fb2edit.lintest.ru/"
+SRC_URI="http://fb2edit.lintest.ru/pub/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+DEPEND="dev-libs/libxml2
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ dev-qt/qtwebkit:4
+ dev-qt/qtxmlpatterns:4"
+RDEPEND="${DEPEND}
+ x11-themes/hicolor-icon-theme"
+
+DOCS=( AUTHORS README )
+
+src_prepare() {
+ # drop -g from CFLAGS
+ sed -i -e '/^add_definitions(-W/s/-g//' CMakeLists.txt || die 'sed failed'
+
+ cmake-utils_src_prepare
+}
diff --git a/app-editors/fb2edit/fb2edit-0.0.9.ebuild b/app-editors/fb2edit/fb2edit-0.0.9.ebuild
new file mode 100644
index 000000000000..333147d05e47
--- /dev/null
+++ b/app-editors/fb2edit/fb2edit-0.0.9.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="a WYSIWYG FictionBook (fb2) editor"
+HOMEPAGE="http://fb2edit.lintest.ru/"
+SRC_URI="https://github.com/lintest/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-libs/libxml2
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ dev-qt/qtwebkit:4
+ dev-qt/qtxmlpatterns:4"
+RDEPEND="${DEPEND}
+ x11-themes/hicolor-icon-theme"
+
+DOCS=( AUTHORS README )
+
+PATCHES=( "${FILESDIR}/${P}-fix-compiler-warnings.patch" )
+
+src_prepare() {
+ # drop -g from CFLAGS
+ sed -i -e '/^add_definitions(-W/s/-g//' CMakeLists.txt || die 'sed failed'
+
+ cmake-utils_src_prepare
+}
diff --git a/app-editors/fb2edit/files/fb2edit-0.0.9-fix-compiler-warnings.patch b/app-editors/fb2edit/files/fb2edit-0.0.9-fix-compiler-warnings.patch
new file mode 100644
index 000000000000..7422c505858e
--- /dev/null
+++ b/app-editors/fb2edit/files/fb2edit-0.0.9-fix-compiler-warnings.patch
@@ -0,0 +1,101 @@
+commit 5a378858e83e95f88ffec5e14ae1fd8157101ed0
+Author: Kandrashin Denis <mail@lintest.ru>
+Date: Fri Jul 18 23:03:05 2014 +0400
+
+ Remove compiler warning
+
+diff --git a/source/fb2main.cpp b/source/fb2main.cpp
+index 50c5a80..504ccd8 100644
+--- a/source/fb2main.cpp
++++ b/source/fb2main.cpp
+@@ -27,6 +27,7 @@ FbMainWindow::FbMainWindow(const QString &filename, ViewMode mode)
+ , isSwitched(false)
+ , isUntitled(true)
+ {
++ Q_UNUSED(mode);
+ connect(qApp, SIGNAL(logMessage(QtMsgType, QString)), SLOT(logMessage(QtMsgType, QString)));
+
+ setUnifiedTitleAndToolBarOnMac(true);
+@@ -50,16 +51,22 @@ FbMainWindow::FbMainWindow(const QString &filename, ViewMode mode)
+
+ void FbMainWindow::warning(int row, int col, const QString &msg)
+ {
++ Q_UNUSED(row);
++ Q_UNUSED(col);
+ logMessage(QtWarningMsg, msg.simplified());
+ }
+
+ void FbMainWindow::error(int row, int col, const QString &msg)
+ {
++ Q_UNUSED(row);
++ Q_UNUSED(col);
+ logMessage(QtCriticalMsg, msg.simplified());
+ }
+
+ void FbMainWindow::fatal(int row, int col, const QString &msg)
+ {
++ Q_UNUSED(row);
++ Q_UNUSED(col);
+ logMessage(QtFatalMsg, msg.simplified());
+ }
+
+@@ -164,6 +171,7 @@ void FbMainWindow::createActions()
+ FbTextEdit *text = mainDock->text();
+ FbHeadEdit *head = mainDock->head();
+ FbCodeEdit *code = mainDock->code();
++ Q_UNUSED(head)
+
+ menu = menuBar()->addMenu(tr("&File"));
+ tool = addToolBar(tr("File"));
+diff --git a/source/fb2text.cpp b/source/fb2text.cpp
+index 0ea146f..aa2d276 100644
+--- a/source/fb2text.cpp
++++ b/source/fb2text.cpp
+@@ -37,14 +37,14 @@ FbTextAction::FbTextAction(const QIcon &icon, const QString &text, QWebPage::Web
+ {
+ }
+
+-QAction * FbTextAction::action(QWebPage::WebAction action)
++QAction * FbTextAction::action()
+ {
+ return m_parent->pageAction(m_action);
+ }
+
+ void FbTextAction::updateAction()
+ {
+- if (QAction * act = action(m_action)) {
++ if (QAction * act = action()) {
+ if (isCheckable()) setChecked(act->isChecked());
+ setEnabled(act->isEnabled());
+ }
+@@ -52,7 +52,7 @@ void FbTextAction::updateAction()
+
+ void FbTextAction::connectAction()
+ {
+- if (QAction * act = action(m_action)) {
++ if (QAction * act = action()) {
+ connect(this, SIGNAL(triggered(bool)), act, SIGNAL(triggered(bool)));
+ connect(act, SIGNAL(changed()), this, SLOT(updateAction()));
+ if (isCheckable()) setChecked(act->isChecked());
+@@ -65,7 +65,7 @@ void FbTextAction::connectAction()
+
+ void FbTextAction::disconnectAction()
+ {
+- QAction * act = action(m_action);
++ QAction * act = action();
+ disconnect(act, 0, this, 0);
+ disconnect(this, 0, act, 0);
+ }
+diff --git a/source/fb2text.hpp b/source/fb2text.hpp
+index c1d1cb4..41f8a6c 100644
+--- a/source/fb2text.hpp
++++ b/source/fb2text.hpp
+@@ -169,7 +169,7 @@ private slots:
+ void updateAction();
+
+ private:
+- QAction * action(QWebPage::WebAction action);
++ QAction * action();
+
+ private:
+ QWebPage::WebAction m_action;
diff --git a/app-editors/fb2edit/metadata.xml b/app-editors/fb2edit/metadata.xml
new file mode 100644
index 000000000000..2bc00486b218
--- /dev/null
+++ b/app-editors/fb2edit/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>pinkbyte@gentoo.org</email>
+ <name>Sergey Popov</name>
+ </maintainer>
+ <upstream>
+ <maintainer>
+ <email>mail@lintest.ru</email>
+ <name>Denis Kandrashin</name>
+ </maintainer>
+ <remote-id type="github">lintest/fb2edit</remote-id>
+ </upstream>
+</pkgmetadata>