summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-editors/joe/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-editors/joe/files')
-rw-r--r--app-editors/joe/files/joe-3.5-ftyperc.patch43
-rw-r--r--app-editors/joe/files/joe-3.7-ftyperc.patch43
-rw-r--r--app-editors/joe/files/joe-3.7-sanitise-includes.patch36
-rw-r--r--app-editors/joe/files/joe-3.7-segfault-fix.patch17
4 files changed, 139 insertions, 0 deletions
diff --git a/app-editors/joe/files/joe-3.5-ftyperc.patch b/app-editors/joe/files/joe-3.5-ftyperc.patch
new file mode 100644
index 000000000000..834b57690440
--- /dev/null
+++ b/app-editors/joe/files/joe-3.5-ftyperc.patch
@@ -0,0 +1,43 @@
+--- rc/ftyperc 2006-07-20 16:35:56.000000000 +0100
++++ rc/ftyperc.gentoo 2013-04-05 15:05:11.000000000 +0100
+@@ -709,3 +709,40 @@
+ *jpicorc.in
+ -syntax joerc
+
++ Gentoo files
++*.ebuild
++-autoindent
++-syntax sh
++-pound_comment
++-text_delimiters do=done:if=elif=else=fi:case=esac
++-smarthome
++-smartbacks
++-indentc 9
++-istep 1
++-tab 4
++
++*.eclass
++-autoindent
++-syntax sh
++-pound_comment
++-text_delimiters do=done:if=elif=else=fi:case=esac
++-smarthome
++-smartbacks
++-indentc 9
++-istep 1
++-tab 4
++
++*/etc/portage/*
++-syntax conf
++
++*/make.conf
++-syntax sh
++
++*/etc/conf.d/*
++-syntax conf
++
++*/etc/env.d/*
++-syntax conf
++
++*/usr/portage/profiles/*
++-syntax conf
diff --git a/app-editors/joe/files/joe-3.7-ftyperc.patch b/app-editors/joe/files/joe-3.7-ftyperc.patch
new file mode 100644
index 000000000000..e570d6b1864f
--- /dev/null
+++ b/app-editors/joe/files/joe-3.7-ftyperc.patch
@@ -0,0 +1,43 @@
+--- rc/ftyperc 2008-10-31 01:42:29.000000000 +0000
++++ rc/ftyperc.gentoo 2013-04-05 15:04:49.000000000 +0100
+@@ -753,3 +753,40 @@
+ *jpicorc.in
+ -syntax joerc
+
++ Gentoo files
++*.ebuild
++-autoindent
++-syntax sh
++-pound_comment
++-text_delimiters do=done:if=elif=else=fi:case=esac
++-smarthome
++-smartbacks
++-indentc 9
++-istep 1
++-tab 4
++
++*.eclass
++-autoindent
++-syntax sh
++-pound_comment
++-text_delimiters do=done:if=elif=else=fi:case=esac
++-smarthome
++-smartbacks
++-indentc 9
++-istep 1
++-tab 4
++
++*/etc/portage/*
++-syntax conf
++
++*/make.conf
++-syntax sh
++
++*/etc/conf.d/*
++-syntax conf
++
++*/etc/env.d/*
++-syntax conf
++
++*/usr/portage/profiles/*
++-syntax conf
diff --git a/app-editors/joe/files/joe-3.7-sanitise-includes.patch b/app-editors/joe/files/joe-3.7-sanitise-includes.patch
new file mode 100644
index 000000000000..0d60cdb41e18
--- /dev/null
+++ b/app-editors/joe/files/joe-3.7-sanitise-includes.patch
@@ -0,0 +1,36 @@
+injecting random paths breaks random on Prefix platforms
+
+--- configure.ac
++++ configure.ac
+@@ -23,14 +23,6 @@
+ AC_PROG_INSTALL
+ AC_PROG_LN_S
+
+-case "$host" in
+- *-*-solaris*)
+- CPPFLAGS="$CPPFLAGS -I/usr/local/include"
+- LDFLAGS="$LDFLAGS -L/usr/local/lib -R/usr/local/lib"
+- ;;
+- *) ;;
+-esac
+-
+ search_libs="$search_libs m"
+
+ # Checks for libraries.
+--- configure
++++ configure
+@@ -4071,14 +4071,6 @@
+ fi
+
+
+-case "$host" in
+- *-*-solaris*)
+- CPPFLAGS="$CPPFLAGS -I/usr/local/include"
+- LDFLAGS="$LDFLAGS -L/usr/local/lib -R/usr/local/lib"
+- ;;
+- *) ;;
+-esac
+-
+ search_libs="$search_libs m"
+
+ # Checks for libraries.
diff --git a/app-editors/joe/files/joe-3.7-segfault-fix.patch b/app-editors/joe/files/joe-3.7-segfault-fix.patch
new file mode 100644
index 000000000000..38efac2e30c4
--- /dev/null
+++ b/app-editors/joe/files/joe-3.7-segfault-fix.patch
@@ -0,0 +1,17 @@
+Index: main.c
+===================================================================
+RCS file: /cvsroot/joe-editor/joe-current/main/main.c,v
+retrieving revision 1.5
+retrieving revision 1.6
+diff -u -r1.5 -r1.6
+--- main.c 27 Oct 2008 01:57:13 -0000 1.5
++++ main.c 23 Nov 2008 21:32:15 -0000 1.6
+@@ -431,7 +431,7 @@
+ b->orphan = 1;
+ b->oldcur = pdup(b->bof, USTR "main");
+ pline(b->oldcur, get_file_pos(b->name));
+- p_goto_bol(bw->cursor);
++ p_goto_bol(b->oldcur);
+ line = b->oldcur->line - (maint->h - 1) / 2;
+ if (line < 0)
+ line = 0;