summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-08-05 15:31:11 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-08-05 15:31:11 +0300
commit5591a75309c90aebe5cc54134422b2017b36887d (patch)
treee1be0c6bceec4aae5f217bc98a34074dd2a425e1 /app-editors/vscodium
parentdev-python/pyproject-fmt: Keyword 0.3.4 ia64, #861344 (diff)
downloadgentoo-5591a75309c90aebe5cc54134422b2017b36887d.tar.gz
gentoo-5591a75309c90aebe5cc54134422b2017b36887d.tar.bz2
gentoo-5591a75309c90aebe5cc54134422b2017b36887d.zip
app-editors/vscodium: add 1.70.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-editors/vscodium')
-rw-r--r--app-editors/vscodium/Manifest3
-rw-r--r--app-editors/vscodium/vscodium-1.70.0.ebuild114
2 files changed, 117 insertions, 0 deletions
diff --git a/app-editors/vscodium/Manifest b/app-editors/vscodium/Manifest
index 46df94672c02..9930be3b3f38 100644
--- a/app-editors/vscodium/Manifest
+++ b/app-editors/vscodium/Manifest
@@ -4,3 +4,6 @@ DIST vscodium-1.68.1-arm64.tar.gz 114632027 BLAKE2B 48cf6a5566817e0ae9a9b33f98a3
DIST vscodium-1.69.2-amd64.tar.gz 121116247 BLAKE2B af616419dbf9cb96ab6662a0016013c0f406581f63ca50665b40fa827e3c4a142132192dcfee2639dc96e99cbb7edac8da26a477acfd5d5ed698535588291c9c SHA512 d1afdaeddd72706c1b51352730c1d8baaaef5e5d5adc7a111f02905704e8ea2886c72617722475a90a14a49a8032c0d120e0b35ff50e602477efc86b5fde6049
DIST vscodium-1.69.2-arm.tar.gz 102920556 BLAKE2B 84a95f6530b7c13f18e2cc569d54a533bef39d13df54591b5d8d1b2d095345fefaaf967414f982d9049b12201c6fc86a256b64c42b3d5c0cc4ec248d26c9c636 SHA512 d1a2443a25262c7b843085abfb0a896120dc234446d3ef1b8306d2a09d7dc7cbdf1da5eb8cfe5c18067cf67941223c1bab124ab71c56b24c2f0951449b3a220b
DIST vscodium-1.69.2-arm64.tar.gz 118959353 BLAKE2B e9a81f208babb84560f391e2a1ee8008add843e00b9d041b07bdce4d4a6cb06f979bdaa5ea1d0d818b0765ec5a726ccf8c26efabd1aa44404bde19addb941cf1 SHA512 bb761cdbbd8b52b0fbcfe21e6d851047a522792e428ce2fe8f917ffc073ee9dfedca0b8c9394385151307f38f709db4bc3c51798c81a5b5730df83786a8b0fe0
+DIST vscodium-1.70.0-amd64.tar.gz 119473836 BLAKE2B 278b071006de89408f5124a38b0dbccaffa10a574397473ba84da41d0f14ec1b472ffbaef6580cc5a033187aecb9d8de39893d0060e3d16e38741840b57a209f SHA512 d0284e25144c01aeebda8e460d5f83aa62a529bc9c97949f037de9515ad387c3b99ff306eafdeb1a2d69a18a90ba284d7acbbfcb469438ba38a9094b9c55bda2
+DIST vscodium-1.70.0-arm.tar.gz 101286329 BLAKE2B aa1862aac41bfcc1836a91933185097abf24664b1a85008603bd0d41154cdcfdf94ae6e9c5885d2762a7b00bbddae5af91f78233f5775c213925992db9969882 SHA512 9565c6c08c6c1dfb8bc1622514eb54220b2453cf697a3f30b85fe67fca9f7a295a525590c5e1b6fa23e9c84f139e54d2425e13c68d872a5a7eb001b945ae5a63
+DIST vscodium-1.70.0-arm64.tar.gz 117321647 BLAKE2B 9a49aa9d77dd2aec1561ff8332953062341fc5c6d37e2130c509941d673c2ff32b490ca6755602b46e635425cc801492ed30a058ef8b5f93b58a9c7619695512 SHA512 da82950cf243bbafebb415bf72127edc63dfa805cb37045c5ffff67f24d28fb811c44aa0d2c3b14098238dbd55c29e384872594ef6d8464af95dea6379cdd071
diff --git a/app-editors/vscodium/vscodium-1.70.0.ebuild b/app-editors/vscodium/vscodium-1.70.0.ebuild
new file mode 100644
index 000000000000..34c1107537e0
--- /dev/null
+++ b/app-editors/vscodium/vscodium-1.70.0.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop pax-utils xdg
+
+DESCRIPTION="A community-driven, freely-licensed binary distribution of Microsoft's VSCode"
+HOMEPAGE="https://vscodium.com/"
+SRC_URI="
+ amd64? ( https://github.com/VSCodium/${PN}/releases/download/${PV}/VSCodium-linux-x64-${PV}.tar.gz -> ${P}-amd64.tar.gz )
+ arm? ( https://github.com/VSCodium/${PN}/releases/download/${PV}/VSCodium-linux-armhf-${PV}.tar.gz -> ${P}-arm.tar.gz )
+ arm64? ( https://github.com/VSCodium/${PN}/releases/download/${PV}/VSCodium-linux-arm64-${PV}.tar.gz -> ${P}-arm64.tar.gz )
+"
+
+RESTRICT="strip bindist"
+
+LICENSE="
+ Apache-2.0
+ BSD
+ BSD-1
+ BSD-2
+ BSD-4
+ CC-BY-4.0
+ ISC
+ LGPL-2.1+
+ MIT
+ MPL-2.0
+ openssl
+ PYTHON
+ TextMate-bundle
+ Unlicense
+ UoI-NCSA
+ W3C
+"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~arm ~arm64"
+IUSE=""
+
+RDEPEND="
+ app-accessibility/at-spi2-atk:2
+ app-accessibility/at-spi2-core:2
+ app-crypt/libsecret[crypt]
+ dev-libs/atk
+ dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ media-libs/alsa-lib
+ media-libs/mesa
+ net-print/cups
+ sys-apps/dbus
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/libdrm
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libxkbcommon
+ x11-libs/libxkbfile
+ x11-libs/libXrandr
+ x11-libs/libxshmfence
+ x11-libs/pango
+"
+
+QA_PREBUILT="
+ /opt/vscodium/chrome_crashpad_handler
+ /opt/vscodium/chrome-sandbox
+ /opt/vscodium/codium
+ /opt/vscodium/libEGL.so
+ /opt/vscodium/libffmpeg.so
+ /opt/vscodium/libGLESv2.so
+ /opt/vscodium/libvk_swiftshader.so
+ /opt/vscodium/libvulkan.so*
+ /opt/vscodium/resources/app/extensions/*
+ /opt/vscodium/resources/app/node_modules.asar.unpacked/*
+ /opt/vscodium/swiftshader/libEGL.so
+ /opt/vscodium/swiftshader/libGLESv2.so
+"
+
+S="${WORKDIR}"
+
+src_install() {
+ # Cleanup
+ rm "${S}/resources/app/LICENSE.txt" || die
+
+ # Install
+ pax-mark m codium
+ insinto "/opt/${PN}"
+ doins -r *
+ fperms +x /opt/${PN}/{,bin/}codium
+ fperms +x /opt/${PN}/chrome_crashpad_handler
+ fperms 4711 /opt/${PN}/chrome-sandbox
+ fperms 755 /opt/${PN}/resources/app/extensions/git/dist/{askpass,git-editor}{,-empty}.sh
+ fperms -R +x /opt/${PN}/resources/app/out/vs/base/node
+ fperms +x /opt/${PN}/resources/app/node_modules.asar.unpacked/@vscode/ripgrep/bin/rg
+ dosym "../../opt/${PN}/bin/codium" "usr/bin/vscodium"
+ dosym "../../opt/${PN}/bin/codium" "usr/bin/codium"
+ domenu "${FILESDIR}/vscodium.desktop"
+ domenu "${FILESDIR}/vscodium-url-handler.desktop"
+ domenu "${FILESDIR}/vscodium-wayland.desktop"
+ domenu "${FILESDIR}/vscodium-url-handler-wayland.desktop"
+ newicon "resources/app/resources/linux/code.png" "vscodium.png"
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ elog "When compared to the regular VSCode, VSCodium has a few quirks"
+ elog "More information at: https://github.com/VSCodium/vscodium/blob/master/DOCS.md"
+}