summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2017-07-01 10:34:04 +0200
committerUlrich Müller <ulm@gentoo.org>2017-07-01 10:35:11 +0200
commit9e3aa0f3e4470acbf013d5048bef5c9230990a98 (patch)
tree818d8785afcb0b80eb5eb41631eedada0292ba67 /app-editors/zile/zile-2.3.24-r2.ebuild
parentapp-editors/zile: Fix build failure with glibc-2.16. (diff)
downloadgentoo-9e3aa0f3e4470acbf013d5048bef5c9230990a98.tar.gz
gentoo-9e3aa0f3e4470acbf013d5048bef5c9230990a98.tar.bz2
gentoo-9e3aa0f3e4470acbf013d5048bef5c9230990a98.zip
app-editors/zile: Bump ebuild to EAPI 6.
Also add slot dependency on ncurses. Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'app-editors/zile/zile-2.3.24-r2.ebuild')
-rw-r--r--app-editors/zile/zile-2.3.24-r2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-editors/zile/zile-2.3.24-r2.ebuild b/app-editors/zile/zile-2.3.24-r2.ebuild
new file mode 100644
index 000000000000..49d18af56379
--- /dev/null
+++ b/app-editors/zile/zile-2.3.24-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Zile is a small Emacs clone"
+HOMEPAGE="https://www.gnu.org/software/zile/"
+SRC_URI="mirror://gnu/zile/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="alpha amd64 ppc sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="test valgrind"
+
+RDEPEND="sys-libs/ncurses:0"
+DEPEND="${RDEPEND}
+ test? ( valgrind? ( dev-util/valgrind ) )"
+
+PATCHES=("${FILESDIR}"/${P}-{userhome,gets}.patch)
+
+src_configure() {
+ econf $(use test && use_with valgrind || echo "--without-valgrind")
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ # FAQ is installed by the build system in /usr/share/zile
+ dodoc AUTHORS BUGS NEWS README THANKS
+
+ # Zile should never install charset.alias (even on non-glibc arches)
+ rm -f "${ED}"/usr/lib/charset.alias
+}