summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-12-19 00:01:09 -0500
committerMatt Turner <mattst88@gentoo.org>2021-12-19 00:01:09 -0500
commitfc1512136442f10dc83d52336790f911f2cd315c (patch)
tree5b09e8e1036df4b8c6f69b7e7ec961d34266b5fc /app-editors
parentgnome-base/gnome-control-center: Version bump to 41.2 (diff)
downloadgentoo-fc1512136442f10dc83d52336790f911f2cd315c.tar.gz
gentoo-fc1512136442f10dc83d52336790f911f2cd315c.tar.bz2
gentoo-fc1512136442f10dc83d52336790f911f2cd315c.zip
app-editors/ghex: Version bump to 3.41.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/ghex/Manifest1
-rw-r--r--app-editors/ghex/ghex-3.41.1.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/app-editors/ghex/Manifest b/app-editors/ghex/Manifest
index 7190209b5e9c..83a1cc9d0766 100644
--- a/app-editors/ghex/Manifest
+++ b/app-editors/ghex/Manifest
@@ -1 +1,2 @@
DIST ghex-3.18.4.tar.xz 1420268 BLAKE2B 70a3027a2c228481ecbc6ae44c0a707c9858453e3af7bfc268b6e32a8496722cf117c1b2ce4dd798795a429dccd24e1fa9cb9d1a8c9c8fb5998243369f76ccc4 SHA512 6121a5986ee7d7f96bf7f401e155f8aa37f076af455bc68e43d1b5b02b63bc9aed3eba5209511d1b659eb4c9093ab5d9601c14a5e868d979e92a6d0ca0cf9ce2
+DIST ghex-3.41.1.tar.xz 1499804 BLAKE2B dd75dc1cc5d847ae3b932ed0bb98b8e15f44943f76f0ba9f053c6770d05e31d211c9f75a910c93c09cf2de143db8fa0eda4fdb876a0ea3ed0534650e7ac36a65 SHA512 5eccf81c41f5ae56bfe5eab0fb843db0095c75080e7dfc0b19a4c71f40f89931e1cbcd2c58744a6b249d16e2a2e4f96513aaac4c41f46d3b5ae8b2bc851851a0
diff --git a/app-editors/ghex/ghex-3.41.1.ebuild b/app-editors/ghex/ghex-3.41.1.ebuild
new file mode 100644
index 000000000000..2cf48df68aff
--- /dev/null
+++ b/app-editors/ghex/ghex-3.41.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="GNOME hexadecimal editor"
+HOMEPAGE="https://wiki.gnome.org/Apps/Ghex"
+
+LICENSE="GPL-2+ FDL-1.1+"
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-libs/atk-1.0.0
+ >=dev-libs/glib-2.31.10:2
+ >=x11-libs/gtk+-3.3.8:3
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-libs/libxml2:2
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}