summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emacs/edb
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emacs/edb')
-rw-r--r--app-emacs/edb/Manifest1
-rw-r--r--app-emacs/edb/edb-1.31.ebuild37
-rw-r--r--app-emacs/edb/files/50edb-gentoo.el4
-rw-r--r--app-emacs/edb/files/edb-1.31-skram-path.patch11
-rw-r--r--app-emacs/edb/metadata.xml5
5 files changed, 58 insertions, 0 deletions
diff --git a/app-emacs/edb/Manifest b/app-emacs/edb/Manifest
new file mode 100644
index 000000000000..3965acd50a6a
--- /dev/null
+++ b/app-emacs/edb/Manifest
@@ -0,0 +1 @@
+DIST edb-1.31.tar.gz 585728 SHA256 f97bc288af71c5011aa6c251ac0bbf458b30b926b1c1a1f12e2cb0470e0e4c38 SHA512 99af00f1e876b490205e9c3b1807d0af0efcd9a5bff018629f00e36d1572f7d05e979d6bfb50f9c15edfe3ad5382fa6f6171f13c638f3143ece53790bdaa31c3 WHIRLPOOL 53f7b8f47ef0030bf5967bf2983602f15aa7bdaf397ffae4598a9a0c6f7b58346e9abb6d118ec65180b6f72534a92221b2a7c01ab1d965e986cca074c4d55dba
diff --git a/app-emacs/edb/edb-1.31.ebuild b/app-emacs/edb/edb-1.31.ebuild
new file mode 100644
index 000000000000..224c3da0debb
--- /dev/null
+++ b/app-emacs/edb/edb-1.31.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="EDB, The Emacs Database"
+HOMEPAGE="http://www.gnuvola.org/software/edb/
+ http://www.emacswiki.org/emacs/EmacsDataBase"
+SRC_URI="http://www.gnuvola.org/software/edb/${P}.tar.gz"
+
+LICENSE="GPL-3+ Texinfo-manual"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+ELISP_PATCHES="${P}-skram-path.patch"
+SITEFILE="50${PN}-gentoo.el"
+
+src_configure() {
+ default
+}
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ emake -j1 \
+ sitelisp="${ED}${SITELISP}" \
+ infodir="${ED}/usr/share/info" \
+ install
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ dodoc AUTHORS BUGS ChangeLog HACKING NEWS README THANKS TODO doc/refcard.ps
+ dodoc -r examples
+}
diff --git a/app-emacs/edb/files/50edb-gentoo.el b/app-emacs/edb/files/50edb-gentoo.el
new file mode 100644
index 000000000000..a2670b65ba31
--- /dev/null
+++ b/app-emacs/edb/files/50edb-gentoo.el
@@ -0,0 +1,4 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'db-find-file "database" "EDB database package" t)
+(autoload 'edb-interact "database" "EDB database package" t)
+(defalias 'edb-EXPERIMENTAL-interact 'edb-interact)
diff --git a/app-emacs/edb/files/edb-1.31-skram-path.patch b/app-emacs/edb/files/edb-1.31-skram-path.patch
new file mode 100644
index 000000000000..75921ca00160
--- /dev/null
+++ b/app-emacs/edb/files/edb-1.31-skram-path.patch
@@ -0,0 +1,11 @@
+--- edb-1.31-orig/skram/GNUmakefile.in
++++ edb-1.31/skram/GNUmakefile.in
+@@ -48,7 +48,7 @@
+ #
+ # Until that change is distributed, here is a workaround:
+ wily-emacs = $(ebatch) \
+- --eval '(add-to-list (quote load-path) (expand-file-name "$(topdir)"))' \
++ --eval '(add-to-list (quote load-path) (expand-file-name "$(topdir)/lisp"))' \
+ --eval '(require (quote database))'
+
+ sk2: skram.data
diff --git a/app-emacs/edb/metadata.xml b/app-emacs/edb/metadata.xml
new file mode 100644
index 000000000000..bc306fe58224
--- /dev/null
+++ b/app-emacs/edb/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+</pkgmetadata>