summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-12-11 01:06:12 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-12-11 01:28:42 +0100
commit4954144ce8057b333afaebbba5454afe331fda65 (patch)
tree4664af59c13a7b228c0a3b94f6d58bcab61e6d9a /app-emacs/magit
parentapp-emacs/ghub: bump to 4.2.0 (diff)
downloadgentoo-4954144ce8057b333afaebbba5454afe331fda65.tar.gz
gentoo-4954144ce8057b333afaebbba5454afe331fda65.tar.bz2
gentoo-4954144ce8057b333afaebbba5454afe331fda65.zip
app-emacs/magit: bump to 4.1.3
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/magit')
-rw-r--r--app-emacs/magit/Manifest1
-rw-r--r--app-emacs/magit/magit-4.1.3.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/app-emacs/magit/Manifest b/app-emacs/magit/Manifest
index f8c29e1dc6c3..647019de2a9c 100644
--- a/app-emacs/magit/Manifest
+++ b/app-emacs/magit/Manifest
@@ -1,2 +1,3 @@
DIST magit-4.1.1.tar.gz 674147 BLAKE2B 4878061957f342aa1c76e8f356a59d6e13ceba35dad6ed0adf4ba59484a3cb9585855aaeec91a40f6dddd9bfa53c0ed0733b506c19be70a5b056ba70dbb27f4e SHA512 c1ab5b4dadf11a0eafcb69ac46c7c1aa19595a1a76e0cf3b8afa987e64c4b525007753179da1e146dab89504f1b436e9141c76025019bd1077d2172beab8105b
DIST magit-4.1.2.tar.gz 675015 BLAKE2B 0ae4ac04d5b7a20d0ac444e9b87819ca98bebb5b66b6a193f5f9be0d050b07319ed6262f20a0167ecc2d34e9f00b80f4f0eed04b1e673a87b056c33cd9fe564d SHA512 c41abb1525e46b6121f8b7339c598c2773ff23ec35f1dbc3392d63b35e656499026e64b0905a2c97ddbb21e4f547ea9cab0c8df9b0b5ff996c26995940c27f79
+DIST magit-4.1.3.tar.gz 676146 BLAKE2B 427f77653d49bab9ce8b29e006597e639b3a125c156976625337b57e1490250c39431515667381c2ab49149d5e4d49d44fe2c0b589f3ee9d11d754e52d3f5e73 SHA512 1f589b9d08e29a072d71e363c4326db341890e25e52d8c5dd75c0f9dd5bb1e663d2fc0d5c6be396dd557318725cc063b7cb0ed2acddbf9fa980c6e36a415edf3
diff --git a/app-emacs/magit/magit-4.1.3.ebuild b/app-emacs/magit/magit-4.1.3.ebuild
new file mode 100644
index 000000000000..fe0cb5bb99dd
--- /dev/null
+++ b/app-emacs/magit/magit-4.1.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="A Git porcelain inside Emacs"
+HOMEPAGE="https://magit.vc/
+ https://github.com/magit/magit/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+fi
+
+S="${WORKDIR}/${P}/lisp"
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DOCS=( ../README.md ../docs/AUTHORS.md ../docs/RelNotes )
+ELISP_TEXINFO="../docs/*.texi"
+SITEFILE="50${PN}-gentoo.el"
+
+RDEPEND="
+ >=app-emacs/compat-30.0.0.0
+ >=app-emacs/dash-2.19.1
+ >=app-emacs/transient-0.7.7
+ >=app-emacs/with-editor-3.4.2
+"
+BDEPEND="
+ ${RDEPEND}
+ sys-apps/texinfo
+"
+RDEPEND+="
+ >=dev-vcs/git-2.44.2
+"
+
+src_prepare() {
+ default
+
+ echo "(setq ${PN}-version \"${PV}\")" > "./${PN}-version.el" || die
+}