summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emacs/mu-cite
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emacs/mu-cite')
-rw-r--r--app-emacs/mu-cite/Manifest2
-rw-r--r--app-emacs/mu-cite/files/50mu-cite-gentoo.el3
-rw-r--r--app-emacs/mu-cite/metadata.xml6
-rw-r--r--app-emacs/mu-cite/mu-cite-8.1_p200709030413.ebuild28
-rw-r--r--app-emacs/mu-cite/mu-cite-8.1_p201202272330.ebuild28
5 files changed, 67 insertions, 0 deletions
diff --git a/app-emacs/mu-cite/Manifest b/app-emacs/mu-cite/Manifest
new file mode 100644
index 000000000000..30e22754150d
--- /dev/null
+++ b/app-emacs/mu-cite/Manifest
@@ -0,0 +1,2 @@
+DIST mu-cite-200709030413.tar.gz 19439 SHA256 17db5bff75e0f24b46b53c8c0e85d7b5063ce114372d9cdb4d4cc23600930985 SHA512 aee355abf8d77ca9ce6d5d2f00e5e8d9a1123b82bb15169bbbdf22c9447c37f1d200ffe1cd05abb61f1011c0d9731d3300d0e5bbf6f10ca6155c00a610a46703 WHIRLPOOL 88fd3f41083599613878ef3f13374da73274dfb3ebf93a4958c7b5978b8be77ea83217ed461052677636020dfc17b392ebfa4e259a2a92f915529db68e5242f8
+DIST mu-cite-201202272330.tar.gz 19212 SHA256 b16b066eed65b6f984d81a8df2ecb53fbd0ce68599f96c7ca3b279a4ad51292f SHA512 78013bed020c46baeecf56bcd155eb6058d11b1d61a0af55b075454601e3cd1a992bdad887e125ffd569782a38e4509d60efdc431ded501c35da096133b475b8 WHIRLPOOL 6605a3b4857b13bddd0847e1d39a03c9cf38dfdb5a8aedc13cc77faf7a5e3e2072d4b8158d91ad1c7cddc7530544bca4c45d4b85a5cc6d8ef978d01c09729822
diff --git a/app-emacs/mu-cite/files/50mu-cite-gentoo.el b/app-emacs/mu-cite/files/50mu-cite-gentoo.el
new file mode 100644
index 000000000000..d6cf435893d4
--- /dev/null
+++ b/app-emacs/mu-cite/files/50mu-cite-gentoo.el
@@ -0,0 +1,3 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'mu-cite-original "mu-cite" nil t)
+(add-hook 'mail-citation-hook (function mu-cite-original))
diff --git a/app-emacs/mu-cite/metadata.xml b/app-emacs/mu-cite/metadata.xml
new file mode 100644
index 000000000000..92d4e62095de
--- /dev/null
+++ b/app-emacs/mu-cite/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+<herd>cjk</herd>
+</pkgmetadata>
diff --git a/app-emacs/mu-cite/mu-cite-8.1_p200709030413.ebuild b/app-emacs/mu-cite/mu-cite-8.1_p200709030413.ebuild
new file mode 100644
index 000000000000..f940ffbd2c5d
--- /dev/null
+++ b/app-emacs/mu-cite/mu-cite-8.1_p200709030413.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit elisp
+
+MY_P="${PN}-${PV#*_p}"
+DESCRIPTION="Message citation utilities for emacsen"
+HOMEPAGE="http://www.jpl.org/elips/mu/"
+SRC_URI="http://www.jpl.org/elips/mu/snapshots/${MY_P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="app-emacs/apel
+ virtual/emacs-flim"
+
+SITEFILE="50${PN}-gentoo.el"
+DOCS="ChangeLog NEWS README.en"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ emake EMACS=emacs
+}
diff --git a/app-emacs/mu-cite/mu-cite-8.1_p201202272330.ebuild b/app-emacs/mu-cite/mu-cite-8.1_p201202272330.ebuild
new file mode 100644
index 000000000000..f940ffbd2c5d
--- /dev/null
+++ b/app-emacs/mu-cite/mu-cite-8.1_p201202272330.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit elisp
+
+MY_P="${PN}-${PV#*_p}"
+DESCRIPTION="Message citation utilities for emacsen"
+HOMEPAGE="http://www.jpl.org/elips/mu/"
+SRC_URI="http://www.jpl.org/elips/mu/snapshots/${MY_P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="app-emacs/apel
+ virtual/emacs-flim"
+
+SITEFILE="50${PN}-gentoo.el"
+DOCS="ChangeLog NEWS README.en"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ emake EMACS=emacs
+}