summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-09-14 17:57:29 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-09-14 18:03:08 +0200
commit606cd1f4858bb39905683be86f504330d7ef03f9 (patch)
tree793953c4decb09ddad645d746b87fe34cb506937 /app-emacs/php-mode
parentapp-emacs/treemacs: bump to 3.0 (diff)
downloadgentoo-606cd1f4858bb39905683be86f504330d7ef03f9.tar.gz
gentoo-606cd1f4858bb39905683be86f504330d7ef03f9.tar.bz2
gentoo-606cd1f4858bb39905683be86f504330d7ef03f9.zip
app-emacs/php-mode: bump to 1.24.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/php-mode')
-rw-r--r--app-emacs/php-mode/Manifest1
-rw-r--r--app-emacs/php-mode/php-mode-1.24.1.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/app-emacs/php-mode/Manifest b/app-emacs/php-mode/Manifest
index 739d759c161b..13104736cd4a 100644
--- a/app-emacs/php-mode/Manifest
+++ b/app-emacs/php-mode/Manifest
@@ -1,2 +1,3 @@
DIST php-mode-1.23.0.tar.gz 94451 BLAKE2B 324eda995ba8d93ca9bec691c88b05caac3d6786b2d1caac39dc34f513e8a026b3803ad3712729b147a8ee839fe337bf11ebaa1b718cb4c741997a9e1c9279a3 SHA512 051adf317ac1dc4ae14b3aaad9aa15ef650a74c7c1ff134ff9a26664cc7494b522957d9cbed981ec398e9bdc6ccae4437c628b2fe3535e8f2a95da34363ec88a
DIST php-mode-1.24.0.tar.gz 94715 BLAKE2B 226dfe72153f541d8a7ee396dc3cb49c2b0a26c084a3ea36f812f4e923cf364d3ddca0192b87b5a068a9a19a9cfa1227a91f0793374e513b957764b0c867df3f SHA512 fd26f1f022d20bf3dffb772f3735b244cf7e2b4fe51ed35c6ead4f7a7b21686cecd2db54f882a6622a34e3265b4af68d71b589d5adc79b15be3c5e4019ea026a
+DIST php-mode-1.24.1.tar.gz 98595 BLAKE2B f9f6e6812e7239eb9ec9dfdbb932dc74b85df46d0d4001a745a6ff297d060a5bcb835200b02e0bfb09f2d35b20d0c72e273d84e16ed3e7d95d235a369a0c54cc SHA512 e6459637874aef457b856c8730d6b761de38e251b49a44a51cecbb08ae092d383a59adc77997f2ebe27066cb050db588f0037cf9554a071d4834089e14acd9ac
diff --git a/app-emacs/php-mode/php-mode-1.24.1.ebuild b/app-emacs/php-mode/php-mode-1.24.1.ebuild
new file mode 100644
index 000000000000..d8261dee74fe
--- /dev/null
+++ b/app-emacs/php-mode/php-mode-1.24.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=24
+
+inherit elisp
+
+DESCRIPTION="GNU Emacs major mode for editing PHP code"
+HOMEPAGE="https://github.com/emacs-php/php-mode/"
+SRC_URI="https://github.com/emacs-php/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+S="${WORKDIR}"/${P}/lisp
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+DOCS=( ../AUTHORS.md ../CHANGELOG.md ../CONTRIBUTING.md ../README{,.ja}.md ../docs )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ touch ../tests/project/1/.git || die
+ ${EMACS} ${EMACSFLAGS} -L . -L ../tests -l ../tests/php-mode-test.el \
+ -f ert-run-tests-batch-and-exit || die "tests run failed"
+}