summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-03-26 03:34:40 +0100
committerSam James <sam@gentoo.org>2023-03-26 03:35:10 +0100
commitede594fc156724728e8786399c04a88ed32def63 (patch)
tree23685886c57e14a9c152c93c2935a1aac3185d5a /app-emacs/treesit-auto/treesit-auto-0.6.3.ebuild
parentdev-cpp/curlpp: Stabilize 0.8.1 amd64, #903071 (diff)
downloadgentoo-ede594fc156724728e8786399c04a88ed32def63.tar.gz
gentoo-ede594fc156724728e8786399c04a88ed32def63.tar.bz2
gentoo-ede594fc156724728e8786399c04a88ed32def63.zip
app-emacs/treesit-auto: new package, add 0.6.3
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-emacs/treesit-auto/treesit-auto-0.6.3.ebuild')
-rw-r--r--app-emacs/treesit-auto/treesit-auto-0.6.3.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-emacs/treesit-auto/treesit-auto-0.6.3.ebuild b/app-emacs/treesit-auto/treesit-auto-0.6.3.ebuild
new file mode 100644
index 000000000000..e00a9e82638e
--- /dev/null
+++ b/app-emacs/treesit-auto/treesit-auto-0.6.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=29
+inherit elisp
+
+DESCRIPTION="Automatic installation, usage, and fallback for tree-sitter major modes in Emacs 29"
+HOMEPAGE="https://github.com/renzmann/treesit-auto"
+
+if [[ ${PV} == *_p* ]] ; then
+ MY_COMMIT=""
+ SRC_URI="https://github.com/renzmann/treesit-auto/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/${PN}-${MY_COMMIT}
+else
+ SRC_URI="https://github.com/renzmann/treesit-auto/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+# Needs Emacs 29
+#KEYWORDS="~amd64"
+
+SITEFILE="50${PN}-gentoo.el"