summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2025-01-28 22:53:48 +0100
committerMaciej Barć <xgqt@gentoo.org>2025-01-28 23:08:49 +0100
commit5dcf1ceb0df322155f1d4ed42c06c8912ecf4e91 (patch)
tree40bedf85d28942c79ec0e53afa82d4738575a977 /app-emacs/vertico
parentapp-emacs/exwm: bump to 0.33 (diff)
downloadgentoo-5dcf1ceb0df322155f1d4ed42c06c8912ecf4e91.tar.gz
gentoo-5dcf1ceb0df322155f1d4ed42c06c8912ecf4e91.tar.bz2
gentoo-5dcf1ceb0df322155f1d4ed42c06c8912ecf4e91.zip
app-emacs/vertico: bump to 1.11
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/vertico')
-rw-r--r--app-emacs/vertico/Manifest1
-rw-r--r--app-emacs/vertico/vertico-1.11.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/app-emacs/vertico/Manifest b/app-emacs/vertico/Manifest
index b5b263a9aed4..2e7c67cd16e8 100644
--- a/app-emacs/vertico/Manifest
+++ b/app-emacs/vertico/Manifest
@@ -1,2 +1,3 @@
DIST vertico-1.10.tar.gz 48108 BLAKE2B c98deaf0add6542d629e03ca9fcf6f4c8a89ff660d3332b01cf9f85615263c1f1df13d5c7b159e4e2b0393ee1920e9c60551f8f787f1a290d72001f2b1724e6a SHA512 047babb52189a8a94c523bde3514832649cd85c063ea530033cb1212cfb81ab72c01f009c4d7041a29ed8bd97a95bcf4463ecbd7b530e2eab1dc5cfc63322347
+DIST vertico-1.11.gh.tar.gz 48249 BLAKE2B 78b2bf67185e0011171f93b81558fad87d211acd70df85ec2c03eb53a70360f96aaaf17f75160d8c88ea1f2e19169e8e6aa0fb56a3b682f5f3bbbb454654e198 SHA512 fe5b36af784381957594089c48587a951177b2d6c49c689dacbcf6e361f2cf3e0be08224912087767d13534a37105a014a43f3af276a7211d584044e2bc90c17
DIST vertico-1.9.tar.gz 48052 BLAKE2B 21642d1449a2628e0a42e79ed7d35bdcc5a186a72ee69339a9dabdcd25ebff0352e6bb80714e39af804a19dc5d1623b6207a046078d17f173057a24a9778379c SHA512 f56d42412a827c7516d530bc2096f804fb264f97bd0a62ef9ecec8e8975045f7af646f01720dfa1e6b4d846e531dc726e9609e6e73c0ea7082652b5676ee2db7
diff --git a/app-emacs/vertico/vertico-1.11.ebuild b/app-emacs/vertico/vertico-1.11.ebuild
new file mode 100644
index 000000000000..49dee1806f65
--- /dev/null
+++ b/app-emacs/vertico/vertico-1.11.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS="28.1"
+
+inherit elisp
+
+DESCRIPTION="Vertical interactive completion"
+HOMEPAGE="https://github.com/minad/vertico/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/minad/${PN}"
+else
+ SRC_URI="https://github.com/minad/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ >=app-emacs/compat-30.0.2.0
+"
+BDEPEND="
+ ${RDEPEND}
+"
+
+DOCS=( CHANGELOG.org README.org )
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ default
+
+ mv ./extensions/*.el ./ || die
+}
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}