summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-09-10 16:58:08 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-09-10 17:35:31 +0200
commit504783556d880f4e5c3f3b1b63f7ec9b36932ebd (patch)
treea3704004f55deb09a2b12407940d133d1fa7fba9 /app-emacs
parentapp-emacs/ef-themes: new package; add 1.3.0 (diff)
downloadgentoo-504783556d880f4e5c3f3b1b63f7ec9b36932ebd.tar.gz
gentoo-504783556d880f4e5c3f3b1b63f7ec9b36932ebd.tar.bz2
gentoo-504783556d880f4e5c3f3b1b63f7ec9b36932ebd.zip
app-emacs/ef-themes: add live 9999
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/ef-themes/ef-themes-9999.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-emacs/ef-themes/ef-themes-9999.ebuild b/app-emacs/ef-themes/ef-themes-9999.ebuild
new file mode 100644
index 000000000000..e12280ff911b
--- /dev/null
+++ b/app-emacs/ef-themes/ef-themes-9999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Colourful and legible themes for GNU Emacs"
+HOMEPAGE="https://github.com/protesilaos/ef-themes/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/protesilaos/${PN}.git"
+else
+ SRC_URI="https://github.com/protesilaos/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DOCS=( CHANGELOG.org README.md README.org contrast-ratios.org )
+ELISP_TEXINFO="${PN}.texi"
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp-org-export-to texinfo README.org
+
+ elisp_src_compile
+ elisp-make-autoload-file
+}