summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Smith <matthew@gentoo.org>2022-02-27 09:43:24 +0000
committerMatthew Smith <matthew@gentoo.org>2022-02-27 10:22:50 +0000
commit8b4de17c352543df284ca1b10e90f59e73d1aa66 (patch)
treed5a4c974474aba7885b6b9d1678d488cea44dbd0 /app-emacs
parentx11-terms/zutty: drop 0.10 (diff)
downloadgentoo-8b4de17c352543df284ca1b10e90f59e73d1aa66.tar.gz
gentoo-8b4de17c352543df284ca1b10e90f59e73d1aa66.tar.bz2
gentoo-8b4de17c352543df284ca1b10e90f59e73d1aa66.zip
app-emacs/cmake-font-lock: init at 0.1.12
Signed-off-by: Matthew Smith <matthew@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/cmake-font-lock/Manifest1
-rw-r--r--app-emacs/cmake-font-lock/cmake-font-lock-0.1.12.ebuild31
-rw-r--r--app-emacs/cmake-font-lock/files/50cmake-font-lock-gentoo.el2
-rw-r--r--app-emacs/cmake-font-lock/metadata.xml12
4 files changed, 46 insertions, 0 deletions
diff --git a/app-emacs/cmake-font-lock/Manifest b/app-emacs/cmake-font-lock/Manifest
new file mode 100644
index 000000000000..85cbf633d185
--- /dev/null
+++ b/app-emacs/cmake-font-lock/Manifest
@@ -0,0 +1 @@
+DIST cmake-font-lock-0.1.12.tar.gz 225598 BLAKE2B f3bf11a804d58a92cc09c7e657a66a4f8b56c072b6cfa23184124e931e7a1f238818ac238c6f5d7fd368879bef155c12623837a2b40eb87ae28e7ad5c7bf8d44 SHA512 8ad4d03bfabb0aa9077fc5e8b1444b862934c0df49e4edd673e9f3c1fff702245e796f02e26850ac26fc5ae9134a0522a2648d1d8b5c844316905a3bdcfa2fa7
diff --git a/app-emacs/cmake-font-lock/cmake-font-lock-0.1.12.ebuild b/app-emacs/cmake-font-lock/cmake-font-lock-0.1.12.ebuild
new file mode 100644
index 000000000000..091bbf2cc75f
--- /dev/null
+++ b/app-emacs/cmake-font-lock/cmake-font-lock-0.1.12.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+NEED_EMACS=26
+
+# The upstream does not create git tags for releases.
+# This commit hash corresponds to a bump to 0.1.12 and was published to
+# MELPA.
+MY_HASH=0d6111b36a66013aa9b452e664c93308df3b07e1
+
+inherit elisp
+
+DESCRIPTION="Advanced, type aware, highlight support for CMake"
+HOMEPAGE="https://github.com/Lindydancer/cmake-font-lock"
+SRC_URI="https://github.com/Lindydancer/${PN}/archive/${MY_HASH}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-${MY_HASH}
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+SITEFILE="50${PN}-gentoo.el"
+
+RDEPEND="dev-util/cmake[emacs]"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}
diff --git a/app-emacs/cmake-font-lock/files/50cmake-font-lock-gentoo.el b/app-emacs/cmake-font-lock/files/50cmake-font-lock-gentoo.el
new file mode 100644
index 000000000000..636bf931f80a
--- /dev/null
+++ b/app-emacs/cmake-font-lock/files/50cmake-font-lock-gentoo.el
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(load "@SITELISP@/cmake-font-lock-autoloads" nil t)
diff --git a/app-emacs/cmake-font-lock/metadata.xml b/app-emacs/cmake-font-lock/metadata.xml
new file mode 100644
index 000000000000..51b04c0ae888
--- /dev/null
+++ b/app-emacs/cmake-font-lock/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+</maintainer>
+<upstream>
+ <remote-id type="github">Lindydancer/cmake-font-lock</remote-id>
+</upstream>
+<stabilize-allarches/>
+</pkgmetadata>