summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-07-22 01:15:19 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-07-22 15:09:44 +0200
commitc2ecfe36270d317abb13c6a049b59b9664ef2c70 (patch)
tree428e1c4927c6b8a5841fe22ac1577d690fa22903 /app-emacs
parentapp-emacs/geiser: drop old 0.28.1 (diff)
downloadgentoo-c2ecfe36270d317abb13c6a049b59b9664ef2c70.tar.gz
gentoo-c2ecfe36270d317abb13c6a049b59b9664ef2c70.tar.bz2
gentoo-c2ecfe36270d317abb13c6a049b59b9664ef2c70.zip
app-emacs/geiser: bump to 0.29
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/geiser/Manifest1
-rw-r--r--app-emacs/geiser/geiser-0.29.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/app-emacs/geiser/Manifest b/app-emacs/geiser/Manifest
index c10fa35e6efe..0d81221373c4 100644
--- a/app-emacs/geiser/Manifest
+++ b/app-emacs/geiser/Manifest
@@ -1 +1,2 @@
DIST geiser-0.28.2.tar.bz2 655614 BLAKE2B 6b5f86b5a9776df11c2a0fc331a4ed1d45361953004f6c5e605c158d9663e21e4452afb3ae46d84aebfa5606912a3013d444bcceda7a26e2ded55f8c9e52cfce SHA512 7f9622e31d3d80a8a67565bc35d0846b81c700783dc7f992bf8b8f6c999f1a534f658d23287b5f469f278f54c3970be003632a628b43ba0d03d24e0ceb3a4a75
+DIST geiser-0.29.tar.bz2 655923 BLAKE2B 70e20fa0698b2c363f8d03847449d38e0b4a68aebbccc7be8408f7ce550319b85412ae4678e9ded1aa5b2a3222b1e28414de4a1e877ba23464d1983840fbad3b SHA512 05289a01e5a6b2eeef998d94b3a715924ece0b93ac435d52bbaf120580ad2c0b1f3759d49e1c275c230ad98227e9c53d65e25da9bdf54e508c1613330601cde6
diff --git a/app-emacs/geiser/geiser-0.29.ebuild b/app-emacs/geiser/geiser-0.29.ebuild
new file mode 100644
index 000000000000..648558153f0b
--- /dev/null
+++ b/app-emacs/geiser/geiser-0.29.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Generic interaction mode between Emacs and different Scheme implementations"
+HOMEPAGE="https://gitlab.com/emacs-geiser/geiser/"
+SRC_URI="https://gitlab.com/emacs-geiser/${PN}/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="app-emacs/transient"
+BDEPEND="
+ ${RDEPEND}
+ app-text/texi2html
+ sys-apps/texinfo
+"
+
+DOCS=( readme.org news.org doc/html )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ BYTECOMPFLAGS="-L elisp" elisp-compile elisp/*.el
+
+ emake -C doc info web
+}
+
+src_install() {
+ elisp-install ${PN} elisp/*.el{,c}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+
+ doinfo doc/*.info
+ einstalldocs
+}