summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-10-06 20:18:30 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-10-06 21:51:29 +0200
commitd518c5594414b635346366a9aae50e3a785798e0 (patch)
tree549df9678cb27b3c9ea1b40979fb0ae88c5b6712 /app-emacs
parentapp-emacs/dap-mode: drop old 0.7-r1 (diff)
downloadgentoo-d518c5594414b635346366a9aae50e3a785798e0.tar.gz
gentoo-d518c5594414b635346366a9aae50e3a785798e0.tar.bz2
gentoo-d518c5594414b635346366a9aae50e3a785798e0.zip
app-emacs/deferred: minor tweaks
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/deferred/deferred-0.5.1.ebuild27
1 files changed, 17 insertions, 10 deletions
diff --git a/app-emacs/deferred/deferred-0.5.1.ebuild b/app-emacs/deferred/deferred-0.5.1.ebuild
index a100c8ead3a6..4e20dcf7871a 100644
--- a/app-emacs/deferred/deferred-0.5.1.ebuild
+++ b/app-emacs/deferred/deferred-0.5.1.ebuild
@@ -7,18 +7,24 @@ inherit elisp
DESCRIPTION="Deferred and Concurrent - simple asynchronous functions for Emacs Lisp"
HOMEPAGE="https://github.com/kiwanami/emacs-deferred/"
-SRC_URI="https://github.com/kiwanami/emacs-${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}"/emacs-${P}
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/kiwanami/emacs-${PN}.git"
+else
+ SRC_URI="https://github.com/kiwanami/emacs-${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/emacs-${P}"
+
+ KEYWORDS="amd64 ~arm64 ~x86"
+fi
LICENSE="GPL-3+"
-KEYWORDS="amd64 ~arm64 ~x86"
SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
BDEPEND="
test? (
- app-emacs/ert-runner
app-emacs/undercover
)
"
@@ -27,9 +33,10 @@ DOCS=( README-concurrent.ja.markdown README-concurrent.markdown
README.ja.markdown README.markdown sample )
# "Concurrent" tests pass, "Deferred" tests are malformed
-ELISP_REMOVE="test/${PN}-test.el"
+ELISP_REMOVE="
+ test/${PN}-test.el
+"
+
SITEFILE="50${PN}-gentoo.el"
-src_test() {
- ert-runner --reporter ert+duration || die
-}
+elisp-enable-tests ert-runner test