summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-11-18 02:10:45 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-11-18 02:31:42 +0100
commite4818e95ed5444d257d0226d1ef37c6cdd711bd5 (patch)
tree3a17980f0d5586d7d18ebb12cdae1c5d8aae2630 /app-emacs
parentapp-emacs/ebib: drop old 2.39.3 (diff)
downloadgentoo-e4818e95ed5444d257d0226d1ef37c6cdd711bd5.tar.gz
gentoo-e4818e95ed5444d257d0226d1ef37c6cdd711bd5.tar.bz2
gentoo-e4818e95ed5444d257d0226d1ef37c6cdd711bd5.zip
app-emacs/ebib: bump to 2.40.3
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/ebib/Manifest1
-rw-r--r--app-emacs/ebib/ebib-2.40.3.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/app-emacs/ebib/Manifest b/app-emacs/ebib/Manifest
index cc2dc158a73f..76ac76cbbc0e 100644
--- a/app-emacs/ebib/Manifest
+++ b/app-emacs/ebib/Manifest
@@ -1 +1,2 @@
DIST ebib-2.39.4.tar.gz 1048822 BLAKE2B 66fcfb8139cccee1e4ef5ec23fa8a79849a9b0ef9121a2e901b19b1d0cbdeea3404c9d78588636599ccb8f8af57aa2fe589e9b7b3b8f6ac155b1693c5cf454a4 SHA512 83e3291de1407163854316b5fe2e0bea3363578a8ee9bd75b3ec6e3dbf739b92c3966dca7151eaa40514cd18ddf582cd4bebe18a677432ef2b350458607bd77b
+DIST ebib-2.40.3.tar.gz 1049725 BLAKE2B 651716ed5465a4ef93b149ab84018d7daf3ffa1df404b95625a9c3666a1dbbe3d879f180dae92aa619e70121757c4a3b7f566bfc8aed1542b2828de25775b6ff SHA512 4231f5732990828aa19d9d723fb9b74bf761e8034de24fce4748b95a4d969d5a3bbbdc443b4f1a4a88b945b01ded958ae467da4222b546121513a26759419bd6
diff --git a/app-emacs/ebib/ebib-2.40.3.ebuild b/app-emacs/ebib/ebib-2.40.3.ebuild
new file mode 100644
index 000000000000..823cfbb7b24f
--- /dev/null
+++ b/app-emacs/ebib/ebib-2.40.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=26.1
+
+inherit elisp
+
+DESCRIPTION="BibTeX database manager for Emacs"
+HOMEPAGE="https://joostkremers.github.io/ebib/
+ https://github.com/joostkremers/ebib/"
+SRC_URI="https://github.com/joostkremers/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="app-emacs/parsebib"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ app-emacs/ert-runner
+ app-emacs/with-simulated-input
+ )
+"
+
+DOCS=( README.md docs )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ ert-runner -L . -L test --reporter ert+duration --script test || die
+}
+
+src_install() {
+ elisp_src_install
+ doinfo ${PN}.info
+}