summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-11-09 19:57:59 +0100
committerManuel Rüger <mrueg@gentoo.org>2016-11-09 20:01:37 +0100
commita9cd2557d9c19242704484b20b6b17167a12f2af (patch)
treeecb5afeb45795e53eb917f9e5d1197bbeeca4c03 /app-emulation/containerd
parentmedia-gfx/pqiv: respect EPREFIX, bug #594714 (diff)
downloadgentoo-a9cd2557d9c19242704484b20b6b17167a12f2af.tar.gz
gentoo-a9cd2557d9c19242704484b20b6b17167a12f2af.tar.bz2
gentoo-a9cd2557d9c19242704484b20b6b17167a12f2af.zip
app-emulation/containerd: use hardened USEflag for -fno-PIC
Thanks to WilliamH Package-Manager: portage-2.3.0
Diffstat (limited to 'app-emulation/containerd')
-rw-r--r--app-emulation/containerd/containerd-0.2.4-r1.ebuild9
1 files changed, 3 insertions, 6 deletions
diff --git a/app-emulation/containerd/containerd-0.2.4-r1.ebuild b/app-emulation/containerd/containerd-0.2.4-r1.ebuild
index 4b81e8a432ac..ab4ce7e80243 100644
--- a/app-emulation/containerd/containerd-0.2.4-r1.ebuild
+++ b/app-emulation/containerd/containerd-0.2.4-r1.ebuild
@@ -22,7 +22,7 @@ HOMEPAGE="https://containerd.tools"
LICENSE="Apache-2.0"
SLOT="0"
-IUSE="+seccomp"
+IUSE="hardened +seccomp"
DEPEND=""
RDEPEND=">=app-emulation/runc-1.0.0_rc2
@@ -31,12 +31,9 @@ RDEPEND=">=app-emulation/runc-1.0.0_rc2
S=${WORKDIR}/${P}/src/${EGO_PN}
src_compile() {
- local options=( $(usex seccomp "seccomp") ) myldflags
+ local options=( $(usex seccomp "seccomp") )
export GOPATH="${WORKDIR}/${P}" # ${PWD}/vendor
- if gcc-specs-pie; then
- myldflags="-extldflags -fno-PIC"
- fi
- LDFLAGS=${myldflags} emake GIT_COMMIT="$EGIT_COMMIT" BUILDTAGS="${options[@]}"
+ LDFLAGS=$(usex hardened '-extldflags -fno-PIC' '') emake GIT_COMMIT="$EGIT_COMMIT" BUILDTAGS="${options[@]}"
}
src_install() {