summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-09-15 03:33:18 +0000
committerSam James <sam@gentoo.org>2020-09-15 03:33:18 +0000
commitcf0d8b5f5d46b4bca2f2f7f20fe908a84d7567bb (patch)
tree611fd61aff54ed4b4f361727321d61ccd43893f9 /app-emulation/gxemul
parentapp-emulation/gxemul: bump to EAPI 7 (diff)
downloadgentoo-cf0d8b5f5d46b4bca2f2f7f20fe908a84d7567bb.tar.gz
gentoo-cf0d8b5f5d46b4bca2f2f7f20fe908a84d7567bb.tar.bz2
gentoo-cf0d8b5f5d46b4bca2f2f7f20fe908a84d7567bb.zip
app-emulation/gxemul: bump to 0.6.2
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-emulation/gxemul')
-rw-r--r--app-emulation/gxemul/Manifest1
-rw-r--r--app-emulation/gxemul/gxemul-0.6.2.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/app-emulation/gxemul/Manifest b/app-emulation/gxemul/Manifest
index f2f18056330a..0e40fbe91e05 100644
--- a/app-emulation/gxemul/Manifest
+++ b/app-emulation/gxemul/Manifest
@@ -1 +1,2 @@
DIST gxemul-0.6.0.tar.gz 3598795 BLAKE2B 01bab252b8497379cc819899d9030fd267cf7679a90a421f435c6cb9ce84fedbdbd0ff23a11e0c91a17e41e166488562b4e173b3793cdbc2dd53b70701351429 SHA512 38108c7e4f1332bf80046a63e4a7c5e0fbce7f83a62fdeaa4518ef02947d7de83aac20b0307d286b7eb5d9c721b8400d449d4f244b2bc9358a2502fa21f56b73
+DIST gxemul-0.6.2.tar.gz 5897883 BLAKE2B 9f5b76d955dc3e1a5b1623aaf491f18376456f33cfaa6a4c1633480980c35bb99172075135cfc1ca942ae3b0f34c4eb11c4aec4bc00272da8bb905176ddcea4a SHA512 4f389c509f9ecf39603ceed50e899e2bee285d3fefac9b3214076115ee71b5a7a68d1d92690b6debc8de5cf5f0303da83b3cc921a5c0b5eb4c7ad89baa730b59
diff --git a/app-emulation/gxemul/gxemul-0.6.2.ebuild b/app-emulation/gxemul/gxemul-0.6.2.ebuild
new file mode 100644
index 000000000000..4f73577a5ce6
--- /dev/null
+++ b/app-emulation/gxemul/gxemul-0.6.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="A Machine Emulator, Mainly emulates MIPS, but supports other CPU types"
+HOMEPAGE="http://gxemul.sourceforge.net/"
+SRC_URI="mirror://sourceforge/project/gxemul/GXemul/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~sparc ~x86"
+IUSE="debug X"
+
+RDEPEND="X? ( x11-libs/libX11 )"
+DEPEND="${RDEPEND}
+ X? ( x11-base/xorg-proto )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.6.0-gcc46.patch
+ "${FILESDIR}"/${PN}-0.6.0-no-doxygen.patch
+)
+
+src_prepare() {
+ default
+
+ sed -i configure -e 's|-O3||g' || die "sed configure"
+ tc-export CC CXX
+}
+
+src_configure() {
+ # no autotools
+ ./configure \
+ --disable-valgrind \
+ $(use debug && echo --debug) \
+ $(use X || echo --disable-x) \
+ || die "configure failed"
+}
+
+src_install() {
+ dobin gxemul
+ doman man/gxemul.1
+ dodoc HISTORY README
+ docinto html
+ dodoc -r doc/.
+}