summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <hsoft@hardcoded.net>2017-09-05 08:41:04 -0400
committerAmy Liffey <amynka@gentoo.org>2017-09-21 14:41:18 +0200
commit4a9e5c9e088ffb1d8c4bdc861e45ec25bd6d1f5e (patch)
tree53ca3398d9b2fc2fe75749bef6e62c895dd7acd9 /app-emulation/lxd
parentapp-emulation/lxd: add ipv6 USE flag (diff)
downloadgentoo-4a9e5c9e088ffb1d8c4bdc861e45ec25bd6d1f5e.tar.gz
gentoo-4a9e5c9e088ffb1d8c4bdc861e45ec25bd6d1f5e.tar.bz2
gentoo-4a9e5c9e088ffb1d8c4bdc861e45ec25bd6d1f5e.zip
app-emulation/lxd: Fix the running of tests
They still fail, but at least they run. This also removes our dependency on "golang-build" eclass. Closes:#5621 Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'app-emulation/lxd')
-rw-r--r--app-emulation/lxd/lxd-2.17.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/app-emulation/lxd/lxd-2.17.ebuild b/app-emulation/lxd/lxd-2.17.ebuild
index 910e0b58c9d9..4be344c8be22 100644
--- a/app-emulation/lxd/lxd-2.17.ebuild
+++ b/app-emulation/lxd/lxd-2.17.ebuild
@@ -47,7 +47,7 @@ KEYWORDS="~amd64"
IUSE="+daemon +ipv6 nls test"
-inherit bash-completion-r1 golang-build linux-info systemd user golang-vcs-snapshot
+inherit bash-completion-r1 linux-info systemd user golang-vcs-snapshot
SRC_URI="${ARCHIVE_URI}
${EGO_VENDOR_URI}"
@@ -140,8 +140,10 @@ src_compile() {
src_test() {
if use daemon; then
- # Go native tests should succeed
- golang-build_src_test
+ export GOPATH="${S}"
+ cd "${S}/src/${EGO_PN}" || die "Failed to change to deep src dir"
+
+ emake check
fi
}