summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-03-16 09:04:00 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-03-16 09:05:04 +0100
commit9fbd94d535866efbf5d566269c33107b2cb39d0f (patch)
tree6aa3e578ef9747e4ac6f6aabc70de865da063a56 /app-emulation/virt-firmware
parentapp-emacs/org-roam: install extensions (diff)
downloadgentoo-9fbd94d535866efbf5d566269c33107b2cb39d0f.tar.gz
gentoo-9fbd94d535866efbf5d566269c33107b2cb39d0f.tar.bz2
gentoo-9fbd94d535866efbf5d566269c33107b2cb39d0f.zip
app-emulation/virt-firmware: add openrc service script
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'app-emulation/virt-firmware')
-rw-r--r--app-emulation/virt-firmware/files/kernel-bootcfg-boot-successful9
-rw-r--r--app-emulation/virt-firmware/virt-firmware-24.2-r1.ebuild (renamed from app-emulation/virt-firmware/virt-firmware-24.2.ebuild)3
-rw-r--r--app-emulation/virt-firmware/virt-firmware-24.2_p20240315-r1.ebuild (renamed from app-emulation/virt-firmware/virt-firmware-24.2_p20240315.ebuild)3
3 files changed, 13 insertions, 2 deletions
diff --git a/app-emulation/virt-firmware/files/kernel-bootcfg-boot-successful b/app-emulation/virt-firmware/files/kernel-bootcfg-boot-successful
new file mode 100644
index 000000000000..5c7ef1a79ccf
--- /dev/null
+++ b/app-emulation/virt-firmware/files/kernel-bootcfg-boot-successful
@@ -0,0 +1,9 @@
+#!/sbin/openrc-run
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+description="UKI Successful Boot"
+
+start() {
+ kernel-bootcfg --boot-successful --update-csv || return 1
+}
diff --git a/app-emulation/virt-firmware/virt-firmware-24.2.ebuild b/app-emulation/virt-firmware/virt-firmware-24.2-r1.ebuild
index 9fd059ab7234..60c7279c9636 100644
--- a/app-emulation/virt-firmware/virt-firmware-24.2.ebuild
+++ b/app-emulation/virt-firmware/virt-firmware-24.2-r1.ebuild
@@ -35,6 +35,7 @@ python_install_all() {
doman man/*.1
+ doinitd "${FILESDIR}/kernel-bootcfg-boot-successful"
systemd_dounit systemd/kernel-bootcfg-boot-successful.service
exeinto /usr/lib/kernel/install.d
@@ -43,5 +44,5 @@ python_install_all() {
pkg_postinst() {
optfeature "managing UEFI entries on Unified Kernel Image installation and removal" \
- "sys-boot/shim sys-kernel/installkernel[systemd]"
+ "sys-boot/shim sys-kernel/installkernel[systemd,uki]"
}
diff --git a/app-emulation/virt-firmware/virt-firmware-24.2_p20240315.ebuild b/app-emulation/virt-firmware/virt-firmware-24.2_p20240315-r1.ebuild
index cf1fcb8fc0ef..5eb358eb6555 100644
--- a/app-emulation/virt-firmware/virt-firmware-24.2_p20240315.ebuild
+++ b/app-emulation/virt-firmware/virt-firmware-24.2_p20240315-r1.ebuild
@@ -42,6 +42,7 @@ python_install_all() {
doman man/*.1
+ doinitd "${FILESDIR}/kernel-bootcfg-boot-successful"
systemd_dounit systemd/kernel-bootcfg-boot-successful.service
exeinto /usr/lib/kernel/install.d
@@ -50,5 +51,5 @@ python_install_all() {
pkg_postinst() {
optfeature "managing UEFI entries on Unified Kernel Image installation and removal" \
- "sys-kernel/installkernel[systemd]"
+ "sys-kernel/installkernel[systemd,uki]"
}