summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <crabbedhaloablution@icloud.com>2022-04-05 22:20:14 +0200
committerSam James <sam@gentoo.org>2022-04-10 21:07:10 +0100
commit9683b216e6714e01f52cf54e3eda6167012c4b74 (patch)
tree11af5941b3ef568d8fa98b32bca0c60e8e9a3b0d /app-emulation/virt-manager
parentapp-emulation/wine-staging: Sync with ::wine (diff)
downloadgentoo-9683b216e6714e01f52cf54e3eda6167012c4b74.tar.gz
gentoo-9683b216e6714e01f52cf54e3eda6167012c4b74.tar.bz2
gentoo-9683b216e6714e01f52cf54e3eda6167012c4b74.zip
app-emulation/virt-manager: add fix for setuptools-61 b0rkage
See also: virt-manager/virt-manager#381 Closes: https://bugs.gentoo.org/836645 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Peter Alfredsen <crabbedhaloablution@icloud.com> Closes: https://github.com/gentoo/gentoo/pull/24921 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-emulation/virt-manager')
-rw-r--r--app-emulation/virt-manager/files/virt-manager-4.0.0-setuptools-61-fix.patch34
-rw-r--r--app-emulation/virt-manager/virt-manager-4.0.0.ebuild1
2 files changed, 35 insertions, 0 deletions
diff --git a/app-emulation/virt-manager/files/virt-manager-4.0.0-setuptools-61-fix.patch b/app-emulation/virt-manager/files/virt-manager-4.0.0-setuptools-61-fix.patch
new file mode 100644
index 000000000000..ace16902486c
--- /dev/null
+++ b/app-emulation/virt-manager/files/virt-manager-4.0.0-setuptools-61-fix.patch
@@ -0,0 +1,34 @@
+From c6fc4524d4448259ea85f93f85898b64a4380154 Mon Sep 17 00:00:00 2001
+From: Peter Alfredsen <crabbedhaloablution@icloud.com>
+Date: Tue, 5 Apr 2022 22:04:20 +0200
+Subject: [PATCH] setup: add bits for setuptools-61
+
+Quoting https://github.com/pypa/setuptools/issues/3227
+"Setuptools >= 61, intentionally changes the way packages are built in the
+ sensec that it will try to find files and fail if something is weird.
+
+ Empty packages (like this one), are asked to explicitly add packages=[]
+ to their configuration.
+
+ This intentional change in behaviour is described in
+ https://setuptools.pypa.io/en/latest/history.html#v61-0-0."
+
+Bug: https://bugs.gentoo.org/836645
+Signed-off-by: Peter Alfredsen <crabbedhaloablution@icloud.com>
+---
+ setup.py | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/setup.py b/setup.py
+index e95acd39..7e47e7c7 100755
+--- a/setup.py
++++ b/setup.py
+@@ -547,4 +547,5 @@ setuptools.setup(
+ },
+
+ distclass=VMMDistribution,
++ packages=[],
+ )
+--
+2.35.1
+
diff --git a/app-emulation/virt-manager/virt-manager-4.0.0.ebuild b/app-emulation/virt-manager/virt-manager-4.0.0.ebuild
index fa0f4663c4b9..b5d474327f40 100644
--- a/app-emulation/virt-manager/virt-manager-4.0.0.ebuild
+++ b/app-emulation/virt-manager/virt-manager-4.0.0.ebuild
@@ -58,6 +58,7 @@ distutils_enable_tests pytest
src_prepare() {
distutils-r1_src_prepare
+ eapply "${FILESDIR}/virt-manager-4.0.0-setuptools-61-fix.patch"
}
python_configure() {