summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2022-07-13 08:57:20 +0200
committerFlorian Schmaus <flow@gentoo.org>2022-07-13 09:08:25 +0200
commit9c74cd50bbcf288926c485765f2c6810ef93f139 (patch)
treeae2ef16acf2cb0c7bf769c557c3be65b5d3a2718 /app-emulation/xen-tools
parentnet-wireless/soapyuhd: Keyword 0.4.1 arm, #854291 (diff)
downloadgentoo-9c74cd50bbcf288926c485765f2c6810ef93f139.tar.gz
gentoo-9c74cd50bbcf288926c485765f2c6810ef93f139.tar.bz2
gentoo-9c74cd50bbcf288926c485765f2c6810ef93f139.zip
app-emulation/xen-tools: set OBJDUMP
Closes: https://bugs.gentoo.org/728020 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'app-emulation/xen-tools')
-rw-r--r--app-emulation/xen-tools/xen-tools-4.16.2_pre2.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/app-emulation/xen-tools/xen-tools-4.16.2_pre2.ebuild b/app-emulation/xen-tools/xen-tools-4.16.2_pre2.ebuild
index 84cc9ef221d0..d41e907ed14d 100644
--- a/app-emulation/xen-tools/xen-tools-4.16.2_pre2.ebuild
+++ b/app-emulation/xen-tools/xen-tools-4.16.2_pre2.ebuild
@@ -429,7 +429,16 @@ src_compile() {
local -x NO_WERROR=1
fi
- emake CC="$(tc-getCC)" LD="$(tc-getLD)" AR="$(tc-getAR)" RANLIB="$(tc-getRANLIB)" build-tools ${myopt}
+ emake \
+ HOSTCC="$(tc-getBUILD_CC)" \
+ HOSTCXX="$(tc-getBUILD_CXX)" \
+ CC="$(tc-getCC)" \
+ CXX="$(tc-getCXX)" \
+ LD="$(tc-getLD)" \
+ AR="$(tc-getAR)" \
+ OBJDUMP="$(tc-getOBJDUMP)" \
+ RANLIB="$(tc-getRANLIB)" \
+ build-tools ${myopt}
if use doc; then
emake -C docs build