summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-09-15 03:09:33 +0000
committerSam James <sam@gentoo.org>2020-09-15 03:32:48 +0000
commit00130101a7fb88f14b3685dbcdb8dc3c56a04fdf (patch)
tree47b6b5529c9d16150e32399b1a33269665229ac0 /app-emulation
parentapp-misc/vittk: rename configure.in (diff)
downloadgentoo-00130101a7fb88f14b3685dbcdb8dc3c56a04fdf.tar.gz
gentoo-00130101a7fb88f14b3685dbcdb8dc3c56a04fdf.tar.bz2
gentoo-00130101a7fb88f14b3685dbcdb8dc3c56a04fdf.zip
app-emulation/gxemul: bump to EAPI 7
Closes: https://bugs.gentoo.org/742050 Closes: https://bugs.gentoo.org/734226 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/gxemul/files/gxemul-0.6.0-fix-mkstemp-test.patch (renamed from app-emulation/gxemul/files/0.6.0-fix-mkstemp-test.patch)4
-rw-r--r--app-emulation/gxemul/files/gxemul-0.6.0-fix-mymkstemp.patch (renamed from app-emulation/gxemul/files/0.6.0-fix-mymkstemp.patch)4
-rw-r--r--app-emulation/gxemul/files/gxemul-0.6.0-gcc46.patch (renamed from app-emulation/gxemul/files/0.6.0-gcc46.patch)0
-rw-r--r--app-emulation/gxemul/files/gxemul-0.6.0-no-doxygen.patch21
-rw-r--r--app-emulation/gxemul/gxemul-0.6.0-r1.ebuild24
5 files changed, 41 insertions, 12 deletions
diff --git a/app-emulation/gxemul/files/0.6.0-fix-mkstemp-test.patch b/app-emulation/gxemul/files/gxemul-0.6.0-fix-mkstemp-test.patch
index 88883309b909..cf8b18379cd4 100644
--- a/app-emulation/gxemul/files/0.6.0-fix-mkstemp-test.patch
+++ b/app-emulation/gxemul/files/gxemul-0.6.0-fix-mkstemp-test.patch
@@ -1,5 +1,5 @@
---- configure 2012-11-03 09:08:09.373041529 +0000
-+++ configure.new 2012-11-03 09:08:31.999585979 +0000
+--- a/configure 2012-11-03 09:08:09.373041529 +0000
++++ b/configure 2012-11-03 09:08:31.999585979 +0000
@@ -705,6 +705,7 @@
# mkstemp missing?
printf "checking for mkstemp... "
diff --git a/app-emulation/gxemul/files/0.6.0-fix-mymkstemp.patch b/app-emulation/gxemul/files/gxemul-0.6.0-fix-mymkstemp.patch
index 80d69f92c827..c9e21bcc4b33 100644
--- a/app-emulation/gxemul/files/0.6.0-fix-mymkstemp.patch
+++ b/app-emulation/gxemul/files/gxemul-0.6.0-fix-mymkstemp.patch
@@ -1,5 +1,5 @@
---- src/old_main/misc.cc 2012-11-03 08:47:34.309732354 +0000
-+++ src/old_main/misc.cc.new 2012-11-03 08:47:02.096573614 +0000
+--- a/src/old_main/misc.cc 2012-11-03 08:47:34.309732354 +0000
++++ b/src/old_main/misc.cc 2012-11-03 08:47:02.096573614 +0000
@@ -122,7 +122,7 @@
p++;
}
diff --git a/app-emulation/gxemul/files/0.6.0-gcc46.patch b/app-emulation/gxemul/files/gxemul-0.6.0-gcc46.patch
index eb0ce26b6e1c..eb0ce26b6e1c 100644
--- a/app-emulation/gxemul/files/0.6.0-gcc46.patch
+++ b/app-emulation/gxemul/files/gxemul-0.6.0-gcc46.patch
diff --git a/app-emulation/gxemul/files/gxemul-0.6.0-no-doxygen.patch b/app-emulation/gxemul/files/gxemul-0.6.0-no-doxygen.patch
new file mode 100644
index 000000000000..ea0a20cba061
--- /dev/null
+++ b/app-emulation/gxemul/files/gxemul-0.6.0-no-doxygen.patch
@@ -0,0 +1,21 @@
+We already have pre-generated docs. Don't bother looking for Doxygen.
+----
+diff --git a/configure b/configure
+index c366701..3895d4f 100755
+--- a/configure
++++ b/configure
+@@ -1106,13 +1106,7 @@ rm -f _test_end*
+
+ printf "checking for Doxygen... "
+
+-if (doxygen --version); then
+- # Version is printed, if found.
+- DOXYGEN=doxygen
+-else
+- # Not found is already printed, if doxygen is not found.
+- DOXYGEN="\#"
+-fi
++DOXYGEN="\#"
+
+
+ ###############################################################################
diff --git a/app-emulation/gxemul/gxemul-0.6.0-r1.ebuild b/app-emulation/gxemul/gxemul-0.6.0-r1.ebuild
index c928aefaf117..2dd8d8087fa6 100644
--- a/app-emulation/gxemul/gxemul-0.6.0-r1.ebuild
+++ b/app-emulation/gxemul/gxemul-0.6.0-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="4"
+EAPI=7
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="A Machine Emulator, Mainly emulates MIPS, but supports other CPU types"
HOMEPAGE="http://gxemul.sourceforge.net/"
@@ -18,10 +18,16 @@ RDEPEND="X? ( x11-libs/libX11 )"
DEPEND="${RDEPEND}
X? ( x11-base/xorg-proto )"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.6.0-gcc46.patch
+ "${FILESDIR}"/${P}-fix-mymkstemp.patch # Bug 441558
+ "${FILESDIR}"/${P}-fix-mkstemp-test.patch # Bug 441558
+ "${FILESDIR}"/${PN}-0.6.0-no-doxygen.patch
+)
+
src_prepare() {
- epatch "${FILESDIR}"/${PV}-gcc46.patch
- epatch "${FILESDIR}"/${PV}-fix-mymkstemp.patch # Bug 441558
- epatch "${FILESDIR}"/${PV}-fix-mkstemp-test.patch # Bug 441558
+ default
+
sed -i configure -e 's|-O3||g' || die "sed configure"
tc-export CC CXX
}
@@ -31,12 +37,14 @@ src_configure() {
./configure \
--disable-valgrind \
$(use debug && echo --debug) \
- $(use X || echo --disable-x) || die "configure failed"
+ $(use X || echo --disable-x) \
+ || die "configure failed"
}
src_install() {
dobin gxemul
doman man/gxemul.1
dodoc HISTORY README
- dohtml -r doc/*
+ docinto html
+ dodoc -r doc/.
}